Issues installing charlock_holmes dependency (that's required for gollum gem) deployed on heroku


#1

I’m trying to get a wiki app(making ues of the gollum gem) up
and running in the cloud using heroku for deployment. The app is using
Rails 4.1 with ruby 2.1.2.

While doing a git push heroku master I got an error related to setting
up of the charlock_holmes gem that requires libicu-dev to be
installed on the Heroku platform.

The detailed error is pasted here .

After some research this solution seemed to have an answer that
could be tried but unfortunately I couldn’t get this working for me. I
did try placing the gem in the gemfile but I don’t seem to
understand how can I get away from using the charlock_holmes because
based on my understanding the gem dependencies(the runtime dependencies)
wrt gollum work like -
gollum -> gollum-lib -> gitlab-grit -> charlock_holmes . I’m not sure of
a way to override charlock_holmes gem with charlock_holmes_bundle_icu
and I’m also not sure if it’s a safe bet doing so.

For another workaround I also referred to this article on
installing libicu on heroku. The issue I faced with this solution was I
got the error - no Cedar-supported app detected . I tried to fix
this as well using this solution but I couldn’t really stop from
getting this error when I retried the same solution as that in the
article. I’m relatively new to heroku so I couldn’t really figure
out what I was doing wrong.
I also couldn’t really follow the last set of instructions as to where
exactly can I find the file - .heroku-bundle/config such that I can
place the required information based on the details specified.

Any pointers on how can I get this working would be really handy.
Thanks.