Issue with upgrading to 2.0 on Leopard? Or something else?

Sorry if this has been covered, but I finally decided to upgrade to
Rails 2.0 (running Leopard and previously at rails 1.2.6) so I could
start using some of the great new features. I ran the usual “sudo gem
install rails --include-dependencies” to upgrade and now my
development environment is all out of whack. I suspected MySQL, but
I’ve already made sure I was using the latest MySQL gem and my MySQL
server is running fine. Is there something I’m missing? Here’s the
error (and sorry if this is a n00b question - I’m just starting out
with rails, but I love it!) I get when I load localhost:3000 into my
browser and try to show the info about the application’s environment:

Mysql::Error in Rails/infoController#properties

And here’s the trace:

/Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/
connection_adapters/mysql_adapter.rb:471:in real_connect' /Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/ connection_adapters/mysql_adapter.rb:471:inconnect’
/Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/
connection_adapters/mysql_adapter.rb:165:in initialize' /Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/ connection_adapters/mysql_adapter.rb:88:innew’
/Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/
connection_adapters/mysql_adapter.rb:88:in mysql_connection' /Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/ connection_adapters/abstract/connection_specification.rb:291:insend’
/Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/
connection_adapters/abstract/connection_specification.rb:291:in
connection=' /Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/ connection_adapters/abstract/connection_specification.rb:259:inretrieve_connection’
/Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/
connection_adapters/abstract/connection_specification.rb:78:in
connection' /Library/Ruby/Gems/1.8/gems/activerecord-2.0.1/lib/active_record/ query_cache.rb:8:incache’
/Library/Ruby/Gems/1.8/gems/actionpack-2.0.1/lib/action_controller/
caching.rb:677:in perform_action' /Library/Ruby/Gems/1.8/gems/actionpack-2.0.1/lib/action_controller/ base.rb:524:insend’
/Library/Ruby/Gems/1.8/gems/actionpack-2.0.1/lib/action_controller/
base.rb:524:in process_without_filters' /Library/Ruby/Gems/1.8/gems/actionpack-2.0.1/lib/action_controller/ filters.rb:685:inprocess_without_session_management_support’
/Library/Ruby/Gems/1.8/gems/actionpack-2.0.1/lib/action_controller/
session_management.rb:123:in process' /Library/Ruby/Gems/1.8/gems/actionpack-2.0.1/lib/action_controller/ base.rb:388:inprocess’
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/
dependencies.rb:489:in load' /Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/ dependencies.rb:489:inload’
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/
dependencies.rb:342:in new_constants_in' /Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/ dependencies.rb:489:inload’
/Library/Ruby/Gems/1.8/gems/rails-2.0.1/lib/commands/servers/
mongrel.rb:64
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/
dependencies.rb:496:in require' /Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/ dependencies.rb:342:innew_constants_in’
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.1/lib/active_support/
dependencies.rb:496:in `require’
/Library/Ruby/Gems/1.8/gems/rails-2.0.1/lib/commands/server.rb:39

Any help would be greatly appreciated! Thanks!

Why are you using ‘gem install’ when you want to update a gem?
Run ‘gem help commands’ or ‘gem help update’.

Try removing the gem if the update fails and reinstall.

Good point. I wasn’t really thinking (it was early in the morning)
and I just went by the instructions on the rubyonrails.org blog post
to run gem install…

Should I just delete the “rails-2.0.1” gem or all the related
“activerecord” “actionmailer” and anything else labeled 2.0.1?

Thanks for the help!

On Dec 14, 2007, at 7:02 AM, harm wrote:

Why are you using ‘gem install’ when you want to update a gem?

I used the install command, following the instructions at


and it worked just fine. Because I first updated to gem 0.9.x I was
given the “tip” that you no longer need to “-y” on the install to get
all the dependencies, so on subsequent upgrades (other machines) I’ve
taken that to heart and dropped it. Several install/upgrade processes
have gone flawlessly.

So how do I upgrade?

If you want to move your application to Rails 2.0, you should first
move it to Rails 1.2.6. That’ll include deprecation warnings for most
everything we yanked out in 2.0. So if your application runs fine on
1.2.6 with no deprecation warnings, there’s a good chance that it’ll
run straight up on 2.0. Of course, if you’re using, say, pagination,
you’ll need to install the classic_pagination plugin. If you’re using
Oracle, you’ll need to install the activerecord-oracle-adapter gem.
And so on and so forth for all the extractions.

So how do I install?

To install through gems, do:

gem install rails -y
…if you’re having trouble with that (gem not found), just grab gems
from our own repository in the meanwhile:

gem install rails -y --source http://gems.rubyonrails.org

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs