Issue with scruffy and Rmagick

Hi

I’m trying to create a graph with scruffy but my problem begin with
this part of the code:

graph.render :width => 300, :height => 200,
:to => “x.png”, :as => ‘png’

the thing is that ruby needs the gem Rmagick to execute that code
and I tried to install the gem: gem install rmagick but it fails in
building
the native extensions…

I’m running this application in windows and i have installed the
devkit, with the devkit i successfully installed other gems that
also displayed that error but i can’t install this one…

Someone knows a solution for this?

Or there is a way to display the graph without the need of creating
a img file?

art tav wrote in post #1018734:

the thing is that ruby needs the gem Rmagick to execute that code
and I tried to install the gem: gem install rmagick but it fails in
building
the native extensions…

I’m running this application in windows and i have installed the
devkit, with the devkit i successfully installed other gems that
also displayed that error but i can’t install this one…

Someone knows a solution for this?

To compile Rmagick on Windows has been mentioned on stackoverflow,
RubyInstaller and several places on the internet.

http://groups.google.com/group/rubyinstaller/msg/1d8a22459158126d
http://groups.google.com/group/rubyinstaller/browse_thread/thread/39b3d0e9d2b66649

Or there is a way to display the graph without the need of creating
a img file?

Yes, use something else like Google Graph API or something like that.


Luis L.

There are also prebuilt binaries available for 1.8.x versions. See
http://rmagick.rubyforge.org/install-faq.html#win .

– Matma R.

Thx for the links, issue solved :slight_smile: