Issue with libxml validation block

I have a weird issue with the ruby Libxml2 ruby bindings in a Rails
I use the validate_schema method, with a block which should be called
on each validation error.
The problem is that this block is not always triggered :
specifically, it works with the Webbrick server, but NOT with the
console script, or the thin (which use rack) webserver…
Of course I use exactly the same document and schema.
I’ve tried development and production environments with no change !
Also another difference between Webbrick and Console/Thin, is with the
error handler.
With Console/Thin, &LibXML::XML::Error::VERBOSE_HANDLER is used, since
the error is printed.
However with webbrick nothing is outputted so either there is no
handler, or it’s QUIET_HANDLER
If you need more details than that, please ask…
Also if you feel it’s not a Rails’ problem, please tell me where I can
go !

I tried to check how the gems are loaded in each case, to see any
differences, but I couldn’t figure out how it works !

In environment.rb
config.gem “libxml-ruby”, :lib => ‘xml’, :version => “=1.1.3”

Archlinux :
libxml2 2.7.7-1

rails (2.3.5)
thin (1.2.7)
rubygems-update (1.3.6, 1.3.5)
rack (1.1.0, 1.0.1)


A quick note to add that I don’t think it’s a libxml issue !
If you have any insight of the require process of Rails, more
specifically differences between WebBrick and Console in requiring
gems, I’d be glad to hear about it…

2010/4/2 Clément LAGRANGE [email protected]: