Issue when using MySQL 3.23.41


#1

Hi,

Maybe this is off-topic, but I am having trouble using Rails with an
older version of MySQL.

When I try to run the db:migrate task, I am getting the error:
rake aborted!
Access denied for user: ‘@localhost’ to database ‘testdb’

In my database.yml file I have mentioned a username, but activerecord
does not seem to recognise it :frowning:

Environment:
MySQL: 3.23.41
Rails: 1.1.2
Ruby: 1.8.4

Googling has not helped so far, so any tips are highly appreciated!!

Thanks,
Binil


#2

Binil Thomas wrote:

Maybe this is off-topic, but I am having trouble using Rails with an
older version of MySQL.

OOPS, figured out that the username specified in database.yml was wrong!

Apologetic,
Binil