Issue installing gem Capybara on Debian5 w ruby 1.9.2 ( Rails 3.0.5) => installing native extension

On this server I already installed it in the gemsets for Ruby 1.8.7
and Rails 2.3.11 without any problem …
but trying (many times … ) to install in Ruby 1.9.2 (Rails 3.0.5)
raises an error … It’s not related to the gem itself as the gem
doesn(t build any native extension … but to one dependency…
I don’t know where to start looking for …

here is the log message :
rubyrails:~ ([email protected])$ gem install capybara
Fetching: nokogiri-1.4.4.gem (100%)
Building native extensions. This could take a while…
Fetching: culerity-0.2.15.gem (100%)
Fetching: celerity-0.8.9.gem (100%)
Fetching: json_pure-1.5.1.gem (100%)
Fetching: rubyzip-0.9.4.gem (100%)
Fetching: ffi-1.0.7.gem (100%)
Building native extensions. This could take a while…
ERROR: Error installing capybara:
ERROR: Failed to build gem native extension.

    rake RUBYARCHDIR=/home/kadoudal/.rvm/gems/ruby-1.9.2-

[email protected]/gems/ffi-1.0.7/lib RUBYLIBDIR=/home/kadoudal/.rvm/gems/
[email protected]/gems/ffi-1.0.7/lib
/home/kadoudal/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/
rubygems.rb:388:in bin_path': can't find gem rake ([">= 0"]) with executable rake (Gem::GemNotFoundException) from /home/kadoudal/.rvm/gems/ruby-1.9.2-p180/bin/rake:19:in

need some clue to try solving this issue …

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs