Issue in deploying app in local

Hi All,
I want to run my application with domain name rather than local host
,so i
followed the below steps,but i’m having unable to connect error ,can any
one
help me on this.
gem install passenger
passenger-install-apache2-module

*My rails app location:
/var/www/rails

cd /etc/apache2/sites-available
touch m-lo-lo.com(my virtualhost file)

<VirtualHost 127.0.0.1:8081>
#ServerAdmin [email protected]
ServerName m-lo-lo.com
DocumentRoot “/root/var/www/rails/public/”
<Directory “/root/var/www/rails/public/”>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

RailsEnv production
PassengerMaxPoolSize 25
LogLevel warn
ErrorLog /var/log/apache2/rails/error.log
CustomLog /var/log/apache2/rails/access.log combined

To create symbolic link for virtual host file in “sites-enabled”
directory
ln -s /etc/apche2/sites-available/m-lo-lo.com
/etc/apche2/sites-enabled/
m-lo-lo.com

sudo vi /etc/hosts file

#192.168.21.129 ubuntu # Added by NetworkManager
#127.0.0.1 localhost.localdomain localhost
127.0.0.1 m-lo-lo.com p233
::1 ubuntu localhost6.localdomain6 localhost6
127.0.1.1 ubuntu

The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

vi port.conf
Listen 8081

# If you add NameVirtualHost *:443 here, you will also have to change # the VirtualHost statement in /etc/apache2/sites-available/default-ssl # to # Server Name Indication for SSL named virtual hosts is currently not # supported by MSIE on Windows XP. Listen 443 Listen 443

I created a file "passenger.load "in mod-available directory:

LoadModule passenger_module
/usr/lib/ruby/gems/1.8/gems/passenger-3.0.7/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-3.0.7
PassengerRuby /usr/bin/ruby1.8

a2ensite m-lo-lo.com
Site m-lo-lo.com enabled

/etc/init.d/apache2 reload
/etc/init.d/apache2 restart

mkdir /var/log/apache2/rails/
touch access.log
touch error.log

cd /var/www/rails
touch tmp/restart.txt

hit my browser with
http://m-lo-lo.com
didnt have anything .*

Regards,
Loganathan.s

On 31 May 2011, at 10:49, loganathan sellappa wrote:

<VirtualHost 127.0.0.1:8081>
#ServerAdmin [email protected]
ServerName m-lo-lo.com
DocumentRoot “/root/var/www/rails/public/”

vi port.conf
Listen 8081

hit my browser with
http://m-lo-lo.com
didnt have anything .

Well, it seems like you’re listening only on port 8081 and when you
don’t attach a port number to your URL, every browser assumes port 80.

http://m-lo-lo.com:8081/ will probably do the trick.

If you want it to work without the port at the end of the URL, you’ll
need to make Apache listen on port 80 instead.

Best regards

Peter De Berdt

Sent from my iPhone

On May 31, 2011, at 3:49 AM, loganathan sellappa
[email protected] wrote:

touch m-lo-lo.com(my virtualhost file)

sudo vi /etc/hosts file
ff00::0 ip6-mcastprefix
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl

/etc/init.d/apache2 restart
didnt have anything .

That domain is not registered/does not exist. You would need to purchase
the domain and point it at your server. If you are running this in dev
on you local machine you can just edit the host file.

B.

On 31 May 2011 14:22, Bryan C. [email protected] wrote:

On May 31, 2011, at 3:49 AM, loganathan sellappa [email protected]

wrote:
sudo vi /etc/hosts
127.0.0.1 m-lo-lo.com p233

That domain is not registered/does not exist. You would need to purchase the
domain and point it at your server. If you are running this in dev on you
local machine you can just edit the host file.

He did edit the host[s] file.

Just in case anyone runs into the same issue, it’s documented here:
http://redmine.ruby-lang.org/issues/4611

For me, removing postgres solved the problem. Had planned on moving to
MongoDB anyway . . .

Best Wishes,
Peter

Begin forwarded message:

Hi All,

I’ve got a very simple OmniAuth install. I’ve registered the app with
facebook and the login works fine. When Facebook runs it’s callback
and tries to pull up localhost:3000/auth/facebook/callback, I get a
“page can’t be displayed” in my browser and in the terminal window
where I’m running “rails server” it crashes with a Ruby SegFault.

Here’s the gist: https://gist.github.com/1000515

Bottom line:
Started GET “/auth/facebook” for 127.0.0.1 at 2011-05-31 09:32:48
-0400
/Users/peterbell/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/net/
http.rb:678: [BUG] Segmentation fault
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-darwin10.7.0]

Anyone seen anything like this before at all? I’m running 1.9.2 p180,
Rails 3.1 rc1 and the default version of OmniAuth (0.2.6)

Any suggestions for possible work arounds? I need to knock this app
out pretty quickly, and I love OmniAuth, but this is a bit of a
surprise.

Can’t drop down to Ruby 1.8.7 or Rails 3.0.7/8. Open to trying
OmniAuth 1.0-beta if you think it’d help.

Anyone seen anything like this before? Any input appreciated.

Thanks,
Peter

On Tue, May 31, 2011 at 8:05 AM, Peter B. [email protected] wrote:

Just in case anyone runs into the same issue, it’s documented here:
http://redmine.ruby-lang.org/issues/4611

For me, removing postgres solved the problem. Had planned on moving to
MongoDB anyway . . .

Best Wishes,
Peter

Peter, I have the following questions:

a) Can you post actual error report(s) that you received because many
others with similar configurations may not
so easily switch to another DB engine?

b) Are the gems that you’re using compatible to Ruby 1.9.2 ? For
example,
did you run the unit tests for Postgres
and other gems that may be causing you issues?

c) Does this happen with the latest patch version of Ruby 1.9.2 ? At
this
time, the latest patch for Ruby 1.9.2 is
271.

-Conrad

Wow - that’s kind of bizarre. I know getting rid of the postgres gem
worked because I have pretty modular commits. With the pg gem, segfault.
With sqlite (in dev), no segfault. So while I doubt it’s an issue with
the postgres gem per se, removing the postgres gem (and re-running
bundler) was the only change I made. I even rolled back the change and
confirmed I got the segfault again. I did. No changes in the f/b app
settings during that time, and it had been more than an hour since I’d
created it, so it’s unlikely to be a change I made to the f/b app
settings that was just taking a while to propegate.

Also, following some of the threads out there, the pg gem has been
mentioned by a couple of other people (which was why I thought to try
it).

Interesting . . .

Best Wishes,
Peter

So I had this same issue, I solved it by adding privacy and tos urls
to the fb app. Everything running fine so it probably had nothing to
do with switching to Mongo

Matt

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs