=?iso-8859-1?q?nouveau_=E0_ROR_?=


#1

bonjour la liste

je suis nouveau à ROR et j’avoue être impressionné et excité par les
perspectives.

je possède un powerbook G4 en double boot ubuntu et macosx

j’ai essayé dinstaller ror sur macosx
mais j’ai un message d’erreur

Nidhogg:~/Desktop nicolasg$ sudo gcc_select 3.3
Password:
Default compiler has been set to:
gcc version 3.3 20030304 (Apple Computer, Inc. build 1819)
Nidhogg:~/Desktop nicolasg$ sudo gem install mysql – --with-mysql-
dir=/usr/local/mysql
/usr/local/bin/gem:3:in `require’: No such file to load – rubygems
(LoadError)
from /usr/local/bin/gem:3

auriez vous une idée de comment remédier à cela

merci :wink:

par ailleurs je voudrais aussi tester sur une ubuntu ppc, existe-t-il
un package ou une méthode éprouvée et fiable pour installer tout ceci .

re-merci

NG


#2

Pour Mac OS X, il existe un installeur, mais apparemment le blog de
l’auteur est HS car il a grillé toute sa bande passante, mais comme on
est le 31, ca redeviendra bon demain.

Voici le lien :
http://tonyarnold.com/articles/2005/12/14/ruby-on-rails-1-0-installer

Et tu peux aussi retrouver les billets que j’ai fait dessus sur mon blog
:
http://www.monsieurn.com/billets/149/il-me-faut-aussi-ruby-on-rails-sur-mon-mac
http://www.monsieurn.com/billets/152/ruby-on-rails-sous-mac-os-x-pas-si-facile-que-ca

Le 31/03/06, Gilgam conseil et webdesignremoved_email_address@domain.invalid a écrit :

Nidhogg:~/Desktop nicolasg$ sudo gcc_select 3.3
auriez vous une idée de comment remédier à cela


Railsfrance mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.fr/mailman/listinfo/railsfrance


Nicolas Mérouze


#3

Pour macosx si tu ne maitrise pas trop les bidouilles vu qu’il faut
recompiler ruby et faire quelque autres bidouilles; je te conseille
fortement de tester locomotive
http://locomotive.raaum.org/home/show/HomePage
Bon la version pour rails 1.1 est pas encore sortit, je suis pas trop le
projet mais je pense qu’il vont en sortir une nouvelle version.

Pour l’install pour ubuntu ppc je te conseille l’installation a la main,
les
packages ruby ubuntu on tendance a etre casser et un poil obsolete. Une
fois
ruby installer tu installe rubygems et apres utilise gems pour installer
rails.

Le 31/03/06, Nicolas Mérouze removed_email_address@domain.invalid a écrit :


#4

tu as suvis quoi pour installer RoR ?
ceci
http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger
Je l’ai installé un peu long mais sans problème il faut juste prendre
le temps de tout lire correctement.

Bolo

Le 31/03/06, Gilgam conseil et webdesignremoved_email_address@domain.invalid a écrit :


#5

Le 31 mars 06 à 20:08, Bastien Q. a écrit :

Pour macosx si tu ne maitrise pas trop les bidouilles vu qu’il faut
recompiler ruby et faire quelque autres bidouilles; je te conseille
fortement de tester locomotive
http://locomotive.raaum.org/home/show/HomePage

oui j’avais déjà téléchargé cela mais en effet cela ne fonctionnait pas.

merci du conseil

Bon la version pour rails 1.1 est pas encore sortit, je suis pas
trop le projet mais je pense qu’il vont en sortir une nouvelle
version.

Pour l’install pour ubuntu ppc je te conseille l’installation a la
main, les packages ruby ubuntu on tendance a etre casser et un poil
obsolete. Une fois ruby installer tu installe rubygems et apres
utilise gems pour installer rails.

Pour Mac OS X, il existe un installeur, mais apparemment le blog de
l’auteur est HS car il a grillé toute sa bande passante, mais comme on
est le 31, ca redeviendra bon demain.

Voici le lien :
http://tonyarnold.com/articles/2005/12/14/ruby-on-rails-1-0-installer

Ok j’essaye demain, merci

faut-il tout désinstaller à la main ?

je vous tient au courant

NG


#6

Le 31 mars 06 à 20:49, Bolo M. a écrit :

tu as suvis quoi pour installer RoR ?
ceci
http://hivelogic.com/articles/2005/12/01/
ruby_rails_lighttpd_mysql_tiger
Je l’ai installé un peu long mais sans problème il faut juste prendre
le temps de tout lire correctement.

oui et j’ai en fait utilisé le script de nubyonrails. un peu
fainénant en somme…

mais erreur :frowning:

sinon la bande passante de monsieur l’installeur est toujours dépassée.

NG


conseil formation et webdesign
http://www.gilgam.com
blog
http://babel.ouvaton.org


#7

Il y a le décalage horaire, mais bon, il est 9h30, ca devrait être
réglé. Ce serait con que le site reste HS car son installeur est
vraiment bien.

Le 01/04/06, Gilgam conseil et webdesignremoved_email_address@domain.invalid a écrit :

conseil formation et webdesign


Nicolas Mérouze