Is it possible to undo my mistake

Dear all,

I followed a tutorial online to install a sdr software and accidentaly
deleted files from my gnuradio installation. It took me a very long time
to
manage to set up everyting so before I start from the beginning I wanted
to
ask you if it is possible to undo my mistake. I am on Ubuntu 14.04 LTS
and
did:
cd user/local/lib
sudo rm libgnuradio*

Now when I run gnuradio-companion I get:

Cannot import gnuradio.

Is the python path environment variable set correctly?

  • All OS: PYTHONPATH*

Is the library path environment variable set correctly?

  • Linux: LD_LIBRARY_PATH*
  • Windows: PATH*
  • MacOSX: DYLD_LIBRARY_PATH*

Thank you all!

Thank you very much for the answers.
I removed gnuradio by deleting my pybombs folder and deleting all files
with gnuradio in the filename from my computer. Then I installed pybombs
again and used it to install gnuradio. However now I have two problems
that
I didn’t had before.

  1. When I run the command: “gnuradio-companion” it doen’t work if I
    don’t
    first run “source ~/target/setup_env.sh”.

  2. When I run a flowgraph in grc with a scope sink I get the error
    message:
    “Can’t load image from file
    ‘/usr/share/icons/hicolor/32x32/apps/gnuradio-grc.png’: file does not
    exist.”

Thank you so much for any help. I am new to Ubuntu so that’s probably my
problem…

Best regards

Carl

Probably not without knowing exactly what was accidentally deleted.

What process do you use to install gnuradio that is so difficult to
start
over with? What OS?

On Ubuntu 14.04 using pybombs, it takes me about 35 minutes to
completely
wipe gnuradio from my machine to having it fully installed again. This
should be possible for you too, assuming a standard setup.

v/r,
Rich

On Mon, Apr 27, 2015 at 4:41 PM, Carl O. [email protected]

Add that source command to your .bashrc file which is located in your
home directory. It is a hidden file. Every time you open a new terminal,
the commands in .bashrc are automatically executed for you. After you
add that line, make sure you close all old terminals and use new ones.

The second problem is odd. You’ve made sure the file exists at the
location? If it does, then I would ask if you are using WX Gui
components? They are being phased out and have been discussed as having
issues lately on the mailing list. I never use them. I would recommend
replacing them all with QT components and trying that. Make sure you
change the gui option in your options block too.

Rich

Sent from my iPad

Hi,

Thank you very much for the help! Now it works, for some reason the
solution to the first problem also solved the second or something else
did.

Best regards,

Carl

No sorry It doesn’t work yet… I have a HackRF, and before I reinstalled
gnuradio I found out that if I use an Osmocom source I get an error
saying
no supported device found. But if I started gnuradio with the command
“sudo
gnuradio-companion” then it all worked. However now when I do “sudo
gnuradio-companion” I get “sudo: gnuradio-companion: command not found”.

If I do:

cd target, cd bin, sudo ./gnuradio-companion

I get ->

Cannot import gnuradio.

Is the python path environment variable set correctly?

  • All OS: PYTHONPATH*

Is the library path environment variable set correctly?

  • Linux: LD_LIBRARY_PATH*

  • Windows: PATH*

  • MacOSX: DYLD_LIBRARY_PATH*

Thank you very much in advance if someone knows how to fix this.

Best regards,

Carl

Safest for GNU Radio is package manager. Can’t speak for HackRF, but you
can always use PyBOMBS. If you install GNU Radio through apt-get, and
then HackRF through PyBOMBS, you might need to set GNU Radio as already
installed in PyBOMBS.

Cheers,
Martin

You can also get hackrf libs through Ubuntu’s package manager.

Whatever install method you choose it is best to avoid deleting
installed
libraries unless you really know what you are doing.

-Nathan

On Mon, May 11, 2015 at 12:37 PM, Martin B. [email protected]

Hi all,

I couldn’t solve my problems so I decided to reinstall Ubuntu 14.04 LTS
from the beginning on my hp elitebook 8460p. What is the safest (highest
probability of working) way of installing gnuradio (and hackrf tools)?
I just need a simple installation. Pybombs, build script, package
manager or something else?

Best regards,

Carl

But if you get hackrf libs through Ubuntu’s package manager, do so
before building anything related to HackRF (i.e. before running pybombs,
especially before installing gr-osmosdr); The problem is that a program
links against a specific ABI of a library – in general, against
exactly the same version of the library that was there when the
program was being built. This means that getting hackrf /libhackrf0 from
Ubuntus repositories will not make your version of GNU Radio built
before that installation use that library – you’ll have to recompile
gr-osmosdr to get that functionality.

In fact, if you just use pyBombs’ default setting of installing from deb
if a sufficient version can be found, Hackrf/libhackrf will
automatically be installed from Ubuntu’s repos if you
pybombs install gr-osmosdr

So, my way of doing this would be, on a freshly set up system (with
nothing related to this previously installed):

  • getting pybombs
  • (sudo) ./pybombs install gnuradio gr-osmosdr

and you should get a running system – Ubuntu 14.04 is probably the most
prolific target for pybombs these days, and the defaults should be
“pretty safe”.

Best regards,
Marcus

Thank you all for the help.
I ended up installing it from the package manager and now it works fine.

Best regards,

Carl

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs