Is it possible to run rake on the latest binary release of IronRuby?


#1

Hi All

I was wondering if it was possible to run rake (or irake) on the
latest binary release of IronRuby. I’ve searched the mailing list but
all posts relating to rake are several months old and are not related
to the binary releases :frowning: I’ve tried to run irake but I’m getting
NotImplementedExceptions when I run it. If anybody has suggestions
that would be greatly appreciated.

Thanks

Patrick


#2

It definitely works for me, as I can do things like irake db:migrate,
but this is out of my fork’s railsconf branch; I’ll be making sure the
main repo has all the necessary fixed to run rake and rails without
any major workarounds.

~Jimmy
Sent from my phone

On May 8, 2009, at 4:00 PM, “Patrick van der Velde”
<removed_email_address@domain.invalid


#3

Hiya

Mmm ok I’m a little confused here. So irake does work but possibly not
on the latest binary release? Also does irake need rake under the
covers or should it just be able to run rake files without any link to
Ruby. I haven’t got Ruby installed on my machine (but I do have
ironruby). Also do I need to set any paths etc?
Sorry about all the stupid questions but I’m very new to ironruby (and
ruby actually) so I’m not sure where to search for the solution to my
problem.

Thanks

Patrick

On Sat, May 9, 2009 at 13:35, Jimmy S.


#4

Hi Patrick
You will need the rake gem to be installed in IronRuby for the irake
command
to work.
You can do that with the igem command

igem install rake

I assume you’re using windows because the igem command is broken again
on
mono.

Met vriendelijke groeten - Best regards - Salutations
Ivan Porto C.
Blog: http://flanders.co.nz
Twitter: http://twitter.com/casualjim
Author of IronRuby in Action (http://manning.com/carrero)

Charles
Kuralthttp://www.brainyquote.com/quotes/authors/c/charles_kuralt.html

  • “You can find your way across this country using burger joints the
    way a
    navigator uses stars.”

On Sun, May 10, 2009 at 2:11 AM, Patrick van der Velde <


#5

Hiya

Ok so I installed rake and got:

C:\languages\ironruby\bin>igem install rake
Successfully installed rake-0.8.5
1 gem installed
Installing ri documentation for rake-0.8.5…

Invalid output formatter

For help on options, try ‘rdoc --help’

Then I assume that not having the documentation is not a problem so I
try to run irake but get:

C:\languages\ironruby\bin>irake
:0:in to_proc': The method or operation is not implemented. (System::NotImplementedException) from alt_system.rb:0 from :0:inrequire’
from custom_require.rb:26:in require' from win32.rb:0 from :0:inrequire’
from custom_require.rb:26:in require' from rake.rb:0 from :0:inrequire’
from custom_require.rb:26:in require' from rake:0 from :0:inload’
from irake:0

Any ideas on this one? Am I missing more gems?

Oh and yes I’m on a Windows machine :slight_smile:

Thanks

Patrick