Is anyone using Ruby/Tk on HP-UX 11.11 (PA-RISC)?


Hi, forks!!

I am developing some tools based on ruby/tk. but, I always met the
following errror msgs whenever I tried to execute it.

jykim$ uname -a
HP-UX rp5470 B.11.11 U 9000/800 190494686 unlimited-user license

jykim$ ruby -v
ruby 1.8.7 (2008-06-20 patchlevel 22) [hppa2.0w-hpux11.11]

jykim$ irb
irb(main):001:0> require ‘tk’
LoadError: Bad magic number for shared library: /usr/local/lib/ruby/
1.8/hppa2.0w-hpux11.11/ - /usr/local/lib/ruby/1.8/hppa2.0w-
from /usr/local/lib/ruby/1.8/hppa2.0w-hpux11.11/
from /usr/local/lib/ruby/1.8/tk.rb:6
from (irb):1:in `require’
from (irb):1

jykim$ my_tool
/usr/local/lib/ruby/1.8/hppa2.0w-hpux11.11/ Bad magic
number for shared library: /usr/local/lib/ruby/1.8/hppa2.0w-hpux11.11/ - /usr/local/lib/ruby/1.8/hppa2.0w-hpux11.11/
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in require' from /usr/local/lib/ruby/1.8/tk.rb:6 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 31:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 31:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require’

Testing server is HP-UX 11.11 (PA-RISC).
When I execute this program on other servers such as linux, windows,
solaris, dec…, it is clearly executed.


Sounds like you’ve got a corrupted library, to me, is there a ‘magic’
library in ruby? And I mean as in it’s called magic not -is- magic. =P

If that has nothing to do with this then my next guess is that the tk.rb
file is either corrupted or calling methods/loading code in other

  • jayce

Be forewarned, an idiot just called.

From: “Jun Y. Kim” removed_email_address@domain.invalid
Sent: Monday, February 09, 2009 5:28 PM
To: “ruby-talk ML” removed_email_address@domain.invalid
Subject: Is anyone using Ruby/Tk on HP-UX 11.11 (PA-RISC)?