Is anyone using ferret on Solaris/SPARC?

Ferret throws a bus error in the unit tests under Solaris, sun4u

Bug reporter appears to be on Solaris 8 with Ruby 1.8.4. I’ve tried
on Solaris 10 (first release and 10/06, first without and then with
the most recent patch set), both with Ruby 1.8.6, and get exactly the
same error in the same spot. Tried with 0.11.4 and also a couple of
older versions (0.10.14 and 0.10.7), again get the same error. Would
try HEAD but svn:// seems to be down.

Have tried a couple of different versions of gcc as well. I’m fairly
sure the same compiler was used to compile both Ruby and Ferret.

Just curious if anyone’s gotten Ferret to pass the unit tests on
Solaris. (I’ve also tried just using it but it throws bus errors in
production as well when I try to build the index.)

In case anyone’s familiar enough with the code to suggest a reason why
this might be happening - bus errors always seem to occur on MP_ALLOC
calls. Here’s an example (from 0.11.4):

#0 0xff1c0f90 in _lwp_kill () from /lib/
#1 0xff15fd80 in raise () from /lib/
#2 0xff13ffa0 in abort () from /lib/
#3 0x0009ef44 in rb_bug (fmt=0xb7908 “Bus Error”) at error.c:214
#4 0x0007e0b8 in sigbus (sig=73) at signal.c:605
#5 0xff1bfed0 in __sighndlr () from /lib/
#6 0xff1b4ffc in call_user_handler () from /lib/
#7 0xfdf43668 in dw_add_posting (mp=0x13e7590, curr_plists=0x0,
fld_plists=0xa, doc_num=0, text=0x1e64d2c “policies”, len=8,
pos=1) at index.c:4832
#8 0xfdf437b0 in dw_invert_field (dw=0x1dfab28, fld_inv=0x206c810,
df=0x13e74f0) at index.c:5218
#9 0xfdf43a8c in dw_add_doc (dw=0x1dfab28, doc=0x99f5e0) at
#10 0xfdf44e54 in iw_add_doc (iw=0x1dfaa00, doc=0x99f5e0) at
#11 0xfdf34990 in frt_iw_add_doc (self=27175152, rdoc=27184872) at

Kinda wonder if this is a 64-bit issue though I haven’t made any
attempt to compile these in 64-bit mode…

-Robert Tarrall.-
Unix System/Network Admin
E.Central/Neighborhood Link