IronRuby related gem: iron_maiden

I just pushed v0.2.0 of a gem I have put together called iron_maiden to
gemcutter.

Github: http://github.com/jwthompson2/iron_maiden
Gemcutter: http://gemcutter.org/gems/iron_maiden

It has a basic IronRuby.Rack template that it will copy into an app via
the gem torture command.

It is still quite rough and mostly untested.

I’d love feedback.

Thanks,
James Thompson

James,
I’ve installed using gem and igem without issue, but when I attempt
to run torture, it doesn’t seem to be properly recognized
if I specify a public path. Is there anything special I need to do
with the path?:

gem torture --public TestIMApp1
ERROR: While executing gem … (NoMethodError)
undefined method `call’ for nil:NilClass

igem torture --public TestIMApp1
ERROR: While executing gem … (NoMethodError)
undefined method `call’ for nil:NilClass

However, if I manually create a directory called “public”, then I can
run without any arguments and it seems to setup up appropriately:

mkdir public

igem torture
#Setup message displays properly here.

Best Regards,
Kevin

Looking further, it looks like an issue in rubygems_plugin.rb
Namely, the call to add_option within initialize.

It looks like that should take a block.
Otherwise, I hit the errors mentioned below when rubygems attempts to
parse the arguments
If its working on your end with arguments, is it possible you have an
updated version of rubygems_plugin.rb ?

Best Regards,
Kevin

On Wed, Oct 14, 2009 at 12:01 PM, Kevin R.

Thanks for the patch. Just pushed 0.2.1 to fix the issue you came
across.

-James

Great, thanks for your help.
How did you get it configured for IIS6?
I see you had a struggle with it in some earlier posts, but I didn’t
catch what you did to resolve it.
I’ve tried adding a wildcard handler, and setting to ASP.NET 2.0, but
I get 404 errors when trying to hit anything.

Once I get it working, maybe I can suggest a default config.ru to add
to the site as a placeholder.
Thanks again. Best Regards,
Kevin

The Web.config I include is one that worked for me on one test system.
The two tricks that I haven’t put into the documentation yet is the need
for the wildcard handler like you mention, and also to go to the ASP.NET
tab in your app’s properties and make sure it is set to the 2.0 option
(or better if such exists). I am hoping to get back to my test system
this evening and confirm the steps that need to be described beyond the
Web.config changes.

The other issue is I assume that IronRuby is installed at C:\IronRuby so
there are the library path and gem path settings in Web.config that may
not be right if my assumption is wrong. That is why I want to switch the
Web.config to an ERB template at some point and then attempt to detect
those two elements. But that will cause issues for those prepping their
app on something other than the deployment system.

Like I said, it’s still real rough, but I’m at a point where I need a
tool like this, so hopefully I’ll get it smoothed out quickly.

-James

Nice. Okay, I’ll continue to play around with it. I still have some XP
machines as well, so I might be able to help out with a IIS 5.1 config
once I have IIS 6 working well.
erb template sounds interesting and useful.
Thanks very much for putting this out there.
Thinking a lot about deployment right now myself, so this is a big help

Best Regards,
Kevin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs