IronRuby igem not working


#1

Hi All,

When trying to download the following gems from the cucumber wiki page,
I get the following error:

igem install cucumber —no-ri —no-rdoc
igem install iron-term-ansicolor —no-ri —no-rdoc

ERROR: Could not find a valid gem ‘slimgems’ (>= 0) in any repository
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Errno::ECONNREFUSED: No connection could be made because the target
machine
actively refused it. - connect(2)
(http://rubygems.org/latest_specs.4.8.gz)

In addition I have tried other gems like rake, and get the same error as
above.

I have no connection issues, being able to download gems from webpages
directly (no command line).

I repeated the same on normal ruby (MRI), and got the same error. A

Can anyone shed any light on how to resolve this? Much appreciated.

Many Thanks,
Rahul Dixit


#2

Just as a reminder:

Are you running igem from a powershell or cmd screen that you opened as
administrator?

I usually get that kind of confusing errors if I forget to “run as
administrator”

Regards,

Eduardo