Irb -r gemname produces error


#1

Noobie question: every time I run for example:

irb -r hpricot

I get the error:

…‘require’: no such file to load – hpricot (LoadError)…

and it happens regardless of which gem I wish to require. I do a gem
list and it shows the gems I need are all installed. What am I
overlooking?

Thanks!


#2

Gaudi Mi wrote:

Noobie question: every time I run for example:

irb -r hpricot

I get the error:

…‘require’: no such file to load – hpricot (LoadError)…

and it happens regardless of which gem I wish to require. I do a gem
list and it shows the gems I need are all installed. What am I
overlooking?

Thanks!

Assuming that you’re running Ruby 1.8.x, what you’re missing is a
-rubygems option.