Irb Failing

Hey everyone
So let me begin my story…
I wanted to be awesome in my own mind, so I decided to learn to
program ruby. I installed ruby from source on my mac into /usr/local/
bin and everything went dandy. IRB, erb, rdoc, ri, the whole shebang #!!

Then I decided it was time for me to upgrade.
First, I tried installing ruby from darwinports… No luck…
So then I tried installing it from scratch again, this time in /opt.
Ruby works, erb works, RDoc works, everything EXCEPT irb works.

Here is my error:

[Snow-iMac: ~] ari$ irb
dyld: NSLinkModule() error
dyld: Symbol not found: _rl_filename_completion_function
Referenced from: /opt/ruby-1.8.6/lib/ruby/1.8/powerpc-darwin8.10.0/
readline.bundle
Expected in: flat namespace

Trace/BPT trap

I feel like someone should’ve seen this error before! Turns out Ryan
Davis, one of my many Ruby gods, has. He had a method which felt sort
of hacked together. I haven’t tried it yet, but before I do…

Does anyone have any advice on how to solve or fix this?

Ari
-------------------------------------------|
Nietzsche is my copilot

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs