IPv6 issues viewing any static or dynamic file

Hello,
I am having issues with IPv6 being able to view any files static or
dynamic. I keep getting the error
curl -6 http://ipv6.example.com/test.png

2011/05/14 16:18:36 [info] 6217#0: *1 client timed out (110: Connection
timed out) while sending response to client, client:
xxxx:xxx:xxxx:xxxx:xxx:xxxx:xxxx:xxxx, server: example.com, request:
“GET /test.png HTTP/1.1”, host: “example.com

but i can do HEAD requests and such and get a response.

curl -6 -I ipv6.example.com
HTTP/1.1 200 OK
Server: nginx/1.0.2
Date: Sun, 15 May 2011 08:44:31 GMT
Content-Type: text/html
Content-Length: 0
Last-Modified: Thu, 24 Jan 2008 19:27:58 GMT
Connection: keep-alive
Keep-Alive: timeout=10
Accept-Ranges: bytes

nginx -V
nginx: nginx version: nginx/1.0.2
nginx: TLS SNI support enabled
nginx: configure arguments: --prefix=/usr --sbin-path=/usr/sbin/nginx
–conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error_log --pid-path=/var/run/nginx.pid
–lock-path=/var/lock/nginx.lock --user=nginx --group=nginx
–with-cc-opt=-I/usr/include --with-ld-opt=-L/usr/lib
–http-log-path=/var/log/nginx/access_log
–http-client-body-temp-path=/var/tmp/nginx/client
–http-proxy-temp-path=/var/tmp/nginx/proxy
–http-fastcgi-temp-path=/var/tmp/nginx/fastcgi
–http-scgi-temp-path=/var/tmp/nginx/scgi
–http-uwsgi-temp-path=/var/tmp/nginx/uwsgi --with-ipv6 --with-pcre
–with-http_gzip_static_module --with-http_realip_module
–with-http_ssl_module --without-mail_imap_module
–without-mail_pop3_module --without-mail_smtp_module

and nginx.conf

user nginx nginx;
worker_processes 2;
worker_rlimit_nofile 8192;

error_log /var/log/nginx/error_log info;
#error_log /var/log/nginx/error_log debug;
events {
worker_connections 8192;

worker_connections 1024;

    use epoll;

}

http {
include /etc/nginx/mime.types;

include /etc/nginx/proxy.conf;

    include         /etc/nginx/fastcgi_params;

    default_type    application/octet-stream;

    log_format main
            '$remote_addr - $remote_user [$time_local] '
            '"$request" $status $bytes_sent '
            '"$http_referer" "$http_user_agent" '
            '"$gzip_ratio"';

    client_header_timeout   10;
    client_body_timeout     10;
    #needed for file uploads > 1m
    client_max_body_size    10m;
    send_timeout            10;

    connection_pool_size            256;
    client_header_buffer_size       1k;
    large_client_header_buffers     4 2k;
    request_pool_size               4k;

    gzip on;
    gzip_min_length 1100;
    gzip_buffers    16 8k;
    gzip_static     on;
    gzip_types      text/plain text/css application/x-javascript 

text/xml application/xml application/xml+rss text/javascript;

    output_buffers  1 32k;
    postpone_output 1460;

    sendfile        on;
    tcp_nopush      on;
    tcp_nodelay     on;

    keepalive_timeout       10 10;

    ignore_invalid_headers  on;

    index index.html index.php;
    server {
            listen          [::]:80 default ipv6only=on;
            listen          80 default;
            server_name     example.com www.example.com 

ipv6.example.com;

            access_log      /var/log/nginx/texample.com.access_log 

main;
error_log /var/log/nginx/example.com.error_log
info;

            root /var/www/example.com/htdocs;
            autoindex on;

            location /blog/ {
                    if (!-e $request_filename) {
                            rewrite  ^.+?(/.*\.php)$  /blog$1 

last;
rewrite ^.+?(/wp-.*) /blog$1
last;
rewrite ^
/blog/index.php last;
}
}

            location ~ ^.+\.php {
                    include /etc/nginx/fastcgi_params;
                    fastcgi_param SCRIPT_FILENAME 

/var/www/example.com/htdocs$fastcgi_script_name;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
}

            location ~* ^.+\.(jpg|jpeg|gif|png)$ {
                    access_log   off;
                    expires      30d;
            }

            location ^~ /c/ {
                    return 403;
            }
            location ^~ /p/ {
                    return 403;
            }
    }
    include /etc/nginx/vhosts.d/*.conf;

}

i have turned firewall off to ensure that wasn’t an issue. I am not sure
were else to look.

Here is also a debug log
http://pastie.org/private/dbzwwlkxaelmex47hvwnzq

v/r,
Rob

On Sun, May 15, 2011 at 01:20:06PM +0200, Rob S. wrote:

Server: nginx/1.0.2
Date: Sun, 15 May 2011 08:44:31 GMT
Content-Type: text/html
Content-Length: 0
Last-Modified: Thu, 24 Jan 2008 19:27:58 GMT
Connection: keep-alive
Keep-Alive: timeout=10
Accept-Ranges: bytes

How do you connect via IPv6 ?
It seems like large packets tunneling issue.
Are you able to scp large file via IPv6 ?


Igor S.

On May 15, 2011, at 2:26 PM, Igor S. wrote:

How do you connect via IPv6 ?
It seems like large packets tunneling issue.
Are you able to scp large file via IPv6 ?

I am using a 6to4 HE tunnel on the client side and native IPv6 on the
server side. (It’s hosted at Linode that recently enabled native IPv6)

You are right. I created just a test.txt file with just hello world in
it and i can browse it just fine. I wonder what google is doing because
i can browse ipv6.google.com just fine and other test sights.

Just modified my local MTU to 1280 and it seems to be working now. Sorry
for the noise.

v/r,
Rob

On Sun, May 15, 2011 at 06:10:53PM +0200, Rob S. wrote:

You are right. I created just a test.txt file with just hello world in it and i
can browse it just fine. I wonder what google is doing because i can browse
ipv6.google.com just fine and other test sights.
They might decrease MTU on their side to allow pass large response from
them
to clients.

Just modified my local MTU to 1280 and it seems to be working now. Sorry for the
noise.


Igor S.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs