Internationalization problem

Hi,

I am using the Gloc plugin, and had everything working nicely for one
language, namely English. When I added a second language file
(french), I suddenly can’t load any views without an error. The stack
trace looks like this:

"és "
./script/…/config/…/vendor/plugins/gloc/lib/gloc-internal.rb:147:in
iconv' ./script/../config/../vendor/plugins/gloc/lib/gloc-internal.rb:147:in_set_valu
e_charset’
./script/…/config/…/vendor/plugins/gloc/lib/gloc.rb:181:in
actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:180:ineach’
./script/…/config/…/vendor/plugins/gloc/lib/gloc.rb:180:in
actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:179:inopen’
./script/…/config/…/vendor/plugins/gloc/lib/gloc.rb:179:in
actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:166:ineach’
./script/…/config/…/vendor/plugins/gloc/lib/gloc.rb:166:in
actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc-dev.rb:76:in_assert_gloc_st
rings_up_to_date’
./script/…/config/…/vendor/plugins/gloc/lib/gloc-dev.rb:74:in each' ./script/../config/../vendor/plugins/gloc/lib/gloc-dev.rb:74:in_assert_gloc_st
rings_up_to_date’
(eval):3:in _l' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:17:inl’
./script/…/config/…/app/models/operator_ap_record.rb:43
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/
dependencies.
rb:203:in `load_without_new_constant_marking’

I checked that iconv is installed, and it seems to be, so I don’t
think that is the issue. I also tried explicitly setting the
character set to both utf8 and ISO-8859-1 for the french language
file, but that didn’t seem to make a difference either. Has anybody
else run into this issue, or have any suggestions as to what might be
happening?

Thanks,

Simon