Integrating RadRails with Aptana

C’est tout frais pondu de cet été, donc il y a de bonnes chances pour
que
beaucoup ne connaissent pas encore APTANA.

C’est une IDE Javascript/HTML/XML/CSS de premier ordre basée sur
Eclipse.
Superbe, chapeau bas!
A télécharger tout de suite, avant même de prendre un café.

Mais ce n’est pas tout :
Alors que j’envisageais déja d’utiliser côte à côte Apatana et
Radrails je
tombe sur ceci dans la (superbe) doc en ligne :

http://aptana.com/docs/index.php/Integrating_RadRails_with_Aptana

Que demande le peuple !

Quelqu’un a-t-il déjà essayé ? Avec quelle(s) version(s) de RadRails ?

C’est très beau, comme tout ce qui toute autour d’Eclipse. C’est ça le
problème. Bientôt il faudra utiliser un fork d’Eclipse pour chaque type
de
fichier. Apatana pour coder le JS, HTML, CSS, RadRails pour Rails,
RubyEclipse si c’est pour du simple Ruby (sans Rails), Eclipse avec CDT
tout
seul pour coder mes extensions en C et/ou C++; Et si par un jour de
déprime
je veux faire du Java, je peux utiliser Ecplise tout seul !

Heureusement il y a Textmate ; pour les autres patience (
http://intypelog.blogspot.com/) et si vous êtes un vrai geek avec un
vrai
OS, rien ne remplacera VIM !!!

Greg

2006/8/31, philippe lachaise [email protected]:

2006/8/31, Gregoire LEJEUNE [email protected]:

C’est très beau, comme tout ce qui toute autour d’Eclipse. C’est ça le
problème. Bientôt il faudra utiliser un fork d’Eclipse pour chaque type de
fichier. Apatana pour coder le JS, HTML, CSS, RadRails pour Rails,
RubyEclipse si c’est pour du simple Ruby (sans Rails), Eclipse avec CDT tout
seul pour coder mes extensions en C et/ou C++; Et si par un jour de déprime
je veux faire du Java, je peux utiliser Ecplise tout seul !

Tu peut l’installer en plugin comme radrails et le reste.
J’aime beaucoup Textmate mais quand je suis pas sous mac (et que j’ai de
la
ram) eclipse est assez pratique.

Heureusement il y a Textmate ; pour les autres patience (

C’est une IDE Javascript/HTML/XML/CSS de premier ordre basée sur Eclipse.
Superbe, chapeau bas!
A télécharger tout de suite, avant même de prendre un café.

J’ai essayé, mais la ligne ici est saturée. Je testerai ce soir si tout
va bien.
Les screenshots sont appétissants, et j’ai parcouru rapidement un des
screencasts
pour m’en convaincre.

C’est très beau, comme tout ce qui toute autour d’Eclipse. C’est ça le
problème. Bientôt il faudra utiliser un fork d’Eclipse pour chaque type de
fichier.

En l’occurrence, il me semble que RADRails et Aptana utilise
“Subclipse” (ou autre nom), un Eclipse minimal qui te permet de ne pas
t’embêter à installer en deux fois le programme.
Pour ma part, j’ai installé Eclipse, ajouté le plugin RDT (Ruby
Development Tools) pour faire du Ruby, le plugin RADRails (pour faire
du Rails), et je passe de l’un à l’autre via le bouton “Perspective”.

Heureusement il y a Textmate ; pour les autres patience
(http://intypelog.blogspot.com/) et si vous êtes un vrai geek avec un vrai
OS, rien ne remplacera VIM !!!

Troll velu. Ne pas réagir :stuck_out_tongue:
Et pour Textmate… oui, si j’avais un Mac, et encore, peut-être que
j’utiliserais encore Eclipse.

2006/8/31, Guillaume Zifro DESRAT [email protected]:

Heureusement il y a Textmate ; pour les autres patience
(http://intypelog.blogspot.com/) et si vous êtes un vrai geek avec un vrai
OS, rien ne remplacera VIM !!!

Troll velu. Ne pas réagir :stuck_out_tongue:
Et pour Textmate… oui, si j’avais un Mac, et encore, peut-être que
j’utiliserais encore Eclipse.

Je plaide coupable, cependant s’il est vrai “qu’à l’époque” parler de
Vim et Emacs était clairement un troll annoncé, les choses on changé
et rien que le terme Eclipse me pousse au troll !

Mais bon, je suis sous Mac faut dire ;)))))

Greg

Faut probablement faire un tour là : http://aptana.com/forums/

En particulier sur le thread “Platform
Specifichttp://aptana.com/forums/viewforum.php?f=10

Alors j’ai testé :

J’ai mis à jour mes versions des RDT et de RADRails puis ai installé le
plug-in.
Au changement de perspective, paf ! (voir pièce jointe)

J’ai également testé le binaire Linux en émulation, ça me donne ça :
[[email protected] Aptana]./Aptana_IDE_Setup_Current.bin
Preparing to install…
Extracting the JRE from the installer archive…
Unpacking the JRE…
Extracting the installation resources from the installer archive…
Configuring the installer for this system’s environment…

Launching installer…

./Aptana_IDE_Setup_Current.bin[2473]:
/tmp/install.dir.9697/Linux/resource/jre/bin/java: Permission denied

Et en root :

./Aptana_IDE_Setup_Current.bin

Preparing to install…
Extracting the JRE from the installer archive…
Unpacking the JRE…
Extracting the installation resources from the installer archive…
Configuring the installer for this system’s environment…

Launching installer…

./Aptana_IDE_Setup_Current.bin[2473]:
/tmp/install.dir.15044/Linux/resource/jre/bin/java: Permission denied

Mais comme je suis un gars super sympa, je remonte le /tmp avec les
droits d’exécution, et j’obtiens :

./Aptana_IDE_Setup_Current.bin

Preparing to install…
Extracting the JRE from the installer archive…
Unpacking the JRE…
Extracting the installation resources from the installer archive…
Configuring the installer for this system’s environment…

Launching installer…

Java HotSpot™ Client VM warning: Can’t detect initial thread stack
location

Et ça ne va pas plus loin.

Ma configuration :
[[email protected] ~]uname -a
OpenBSD september.hazzard.info 3.8 GENERIC#138 i386

Le JRE est celui de Sun, version 1.4.2.

Bref, j’essaierai le bundle Windows demain au bureau, mais en
attendant, je suis privé d’Aptana… dommage, ça a l’air bien.

Je viens de tester sur ubuntu dapper avec une install radrails + aptana
en
plugin.
Ca m’a indiqué quelque erreur mais ca fonctionne.
Par contre l’intégration est sans plus, ca peut être pratique pour
éditer du
css mais j’ai des doutes pour les templates rhtml.

2006/8/31, Guillaume Zifro DESRAT [email protected]:

Va falloir encourager les gens de Radrails et d’Aptana à se causer entre
eux
:wink:

Je testais sans grande conviction d’être sûr que ça marche, vu que sur
leur page “System requirements” il ne cite pas de version d’Eclipse
mais des systèmes d’exploitation (et celui que j’utilise n’en fait pas
partie).

Je vais à tout hasard poster un message dans le forum, mais je doute
que ce soit leur priorité de faire fonctionner Aptana sous OpenBSD :slight_smile:

C’est fait RadRails a ete repris par Atana!!!

Quels seront les avantages de cette fusion?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs