Instant Rails on Win XP SP2

I am trying to run instant rails on windows xp SP2. I can get the
cookbook and typo sample sites to work with webrick but not with scgi.

When i click the start with scgi i get a blank dos window and typing returns

Firefox can’t establish a connection to the server at

This suggests that apache is not even running even though the green
light is on for apache and mysql.

The apache access and error logs are also blank.

If i click the apache.exe in the apache folder inside instant rails a
dos window is displayed saying

Apache/1.3 …mod_scgi 1.7 running…

If i type into the browser i get
Firefox can’t establish a connection to the server at

Ive had a look in the readme file inside instant rails and it says the

Apache for Microsoft Windows 2000, NT, 98, and 95
systems. Like the Unix version, it includes many frequently

Is instant rails with aoache/scgi supposed to run on windows xp?

Can anyone help, ive being trying this for days without success???

Try to access the server using its local IP address:


I run it on XP SP2.

You may not be waiting long enough for the SCGI process to get Rails
and the web app loaded and ready to go. It takes about 30 seconds on
my system. I usually watch my cpu-in-use cycles go up when I start the
SCGI process, and when it drops back to zero I know its ready.

Its unfortunate that the SCGI process doesn’t display any status (like
WEBrick) to let you know what’s happening.


I’m assuming that you added the appropriate entries to your windows
HOSTS file.

i m waiting long enough for the scgi process to get rails and the web
app loaded. I have followed the instructions at the link below and
tried some of the common problems without success. I have had IIS
running on this machine but i have disabled it and changed the port
number it listens on. I have norton internet security, could it be
something to do with the firewall?

I am still getting the following below,

Unable to connect

Firefox can’t establish a connection to the server at

Can’t hurt to try it with the firewall disabled.


Hey John, I had the same issue with instant rails on Windows XP w/SP2
but I
simply switched to using Webrick for development purposes because I plan
use the setup that my hosting company has selected for running Rails
After that, I setup RadRails 0.6.2 and I’m good to go. However, it
have been nice to get it working but I need to generate an application
I’ll revisit this in the near future.



I think ive tried everything. I think i will install apache/mysql etc
separetly and go down that route. I used rad rails with eclipse using
webrick for development without any problems. I have a spare machine
here so i’m looking to deploy my site on this machine that is running
windows SP2.

Is apache the best solution for ROR deployment on windows xp s2 or ive
heard some stuff on light server or can webrick be used for ROR

I couldn’t ever get the Instant Rails install to work properly. MySQL
up fine, I couldn’t figure out all the config. Just went back to using

WEBrick is what you want to be using for most development, then move
to Apache when you want to test/develop in an environment that is
closer to what you’ll have in production.


This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs