Installtion problem

Hi ,

 I'm using WindowsXP OS, i successfully installed Ruby and

RubyGems

C:>ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]

C:>gem -v
0.9.4

and i downloaded rails-1.2.5.gem from
http://rubyforge.org/frs/?group_id=307
to my C: Folder

but when i tried to install Rails it is throwing an error

C:>gem install rails --include-dependencies
ERROR: While executing gem … (RuntimeError)
Error instaling rails:
rails requires activesupport = 1.4.4

Please, anyone can solve my prolem ASAP

Thanks
Suchi

try installing with '-include–dependencies ’ option set…

hth
~shishir

whopes, you’ve already tried that… you may want to install it
directly from web… don’t download the tar ( delete it if it’s
present in the current dir) and then run ‘gem install rails’, it
should ask for installing the dependencies automatically…

On Oct 24, 11:19 pm, Shishir Srivastava

Hi,

  I tried to install directly from web also

C:>gem install rails
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
A connection attempt failed because the connected party did not
properly res
pond after a period of time, or established connection failed because
connected
host has failed to respond. - connect(2)(Errno::ETIMEDOUT)

I think it’s behind firewall.

Please, now how can i install Rails on my system.

Thanks
Suchi

On Oct 25, 11:49 am, Shishir Srivastava

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs