Installing sqlite3-ruby on windows not working

Have just reinstalled ruby 1.8.6-26 on windows. Trying to install
sqlite3-ruby it seems to be trying to compile the gem rather than
offering to install the windows binaries from a list of options. Seems
like ruby/gems thinks does not recognise the operating system as
windows. Any ideas?

C:>gem install sqlite3-ruby
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for sqlite3.h… no

make
make: *** No rule to make target ruby.h', needed bysqlite3_api_wrap.o’. Stop
.

Oliver R. wrote:

Have just reinstalled ruby 1.8.6-26 on windows. Trying to install
sqlite3-ruby it seems to be trying to compile the gem rather than
offering to install the windows binaries from a list of options. Seems
like ruby/gems thinks does not recognise the operating system as
windows. Any ideas?

C:>gem install sqlite3-ruby
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for sqlite3.h… no

make
make: *** No rule to make target ruby.h', needed bysqlite3_api_wrap.o’. Stop
.

My own mess created by me.

In case anyone else comes across similar - I have cygwin installed, and
both native ruby and cygwin ruby (and gem) on my path. The two were
getting in a fine mess.

Having Cygwin installed or not isn’t the problem. There isn’t a binary
for windows in the new sqlite3 gem, that is what’s causing the problem.
You’ll need to install a prior version.

Try this:

gem install sqlite3-ruby -v=1.2.3

That should solve your problem.

Oliver R. wrote:

Have just reinstalled ruby 1.8.6-26 on windows. Trying to install
sqlite3-ruby it seems to be trying to compile the gem rather than
offering to install the windows binaries from a list of options. Seems
like ruby/gems thinks does not recognise the operating system as
windows. Any ideas?

C:>gem install sqlite3-ruby
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for sqlite3.h… no

make
make: *** No rule to make target ruby.h', needed bysqlite3_api_wrap.o’. Stop
.

This way help me to fix the problem! Just install developer headers for
provide compile the library from sources.

SQLite3:
Without the -d option, rails will default to sqlite.
To install SQLite3:
~$ sudo apt-get install libsqlite3-0 libsqlite3-dev
~$ sudo gem install sqlite3-ruby

Nick Sardo wrote:

Having Cygwin installed or not isn’t the problem. There isn’t a binary
for windows in the new sqlite3 gem, that is what’s causing the problem.
You’ll need to install a prior version.

Try this:

gem install sqlite3-ruby -v=1.2.3

That should solve your problem.

Oliver R. wrote:

Have just reinstalled ruby 1.8.6-26 on windows. Trying to install
sqlite3-ruby it seems to be trying to compile the gem rather than
offering to install the windows binaries from a list of options. Seems
like ruby/gems thinks does not recognise the operating system as
windows. Any ideas?

C:>gem install sqlite3-ruby
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for sqlite3.h… no

make
make: *** No rule to make target ruby.h', needed bysqlite3_api_wrap.o’. Stop
.

Nick Sardo is quite correct for the Windows environment. Anatoly
Mikhailov has it right for the Linux environment. Apparently
sqlite3-ruby (currently -v=1.2.4) does not have the Windows binary, but
it’s prior release installs perfectly. Thanks Nick, Oliver, and Anatoly!
Very helpful.

gem install sqlite3-ruby -v=1.2.3

Anatoly M. wrote:

This way help me to fix the problem! Just install developer headers for
provide compile the library from sources.

SQLite3:
Without the -d option, rails will default to sqlite.
To install SQLite3:
~$ sudo apt-get install libsqlite3-0 libsqlite3-dev
~$ sudo gem install sqlite3-ruby

Nick Sardo wrote:

Having Cygwin installed or not isn’t the problem. There isn’t a binary
for windows in the new sqlite3 gem, that is what’s causing the problem.
You’ll need to install a prior version.

Try this:

gem install sqlite3-ruby -v=1.2.3

That should solve your problem.

Oliver R. wrote:

Have just reinstalled ruby 1.8.6-26 on windows. Trying to install
sqlite3-ruby it seems to be trying to compile the gem rather than
offering to install the windows binaries from a list of options. Seems
like ruby/gems thinks does not recognise the operating system as
windows. Any ideas?

C:>gem install sqlite3-ruby
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for sqlite3.h… no

make
make: *** No rule to make target ruby.h', needed bysqlite3_api_wrap.o’. Stop
.

The same issue seems to be going on with the “ferret” gem as well. The
current version of ferret is 0.11.6, which is missing the Windows binary
and throws an error on “gem install ferret”. The previous release of
ferret -v=0.11.5 does have the Windows binary and it installs correctly.

So this post helped me install sqlite3-ruby and ferret on Windows.
Thanks Guys!

gem install ferret -v=0.11.5
gem install sqlite3-ruby -v=1.2.3

Marty McGee wrote:

Nick Sardo is quite correct for the Windows environment. Anatoly
Mikhailov has it right for the Linux environment. Apparently
sqlite3-ruby (currently -v=1.2.4) does not have the Windows binary, but
it’s prior release installs perfectly. Thanks Nick, Oliver, and Anatoly!
Very helpful.

gem install sqlite3-ruby -v=1.2.3

Anatoly M. wrote:

This way help me to fix the problem! Just install developer headers for
provide compile the library from sources.

SQLite3:
Without the -d option, rails will default to sqlite.
To install SQLite3:
~$ sudo apt-get install libsqlite3-0 libsqlite3-dev
~$ sudo gem install sqlite3-ruby

Nick Sardo wrote:

Having Cygwin installed or not isn’t the problem. There isn’t a binary
for windows in the new sqlite3 gem, that is what’s causing the problem.
You’ll need to install a prior version.

Try this:

gem install sqlite3-ruby -v=1.2.3

That should solve your problem.

Oliver R. wrote:

Have just reinstalled ruby 1.8.6-26 on windows. Trying to install
sqlite3-ruby it seems to be trying to compile the gem rather than
offering to install the windows binaries from a list of options. Seems
like ruby/gems thinks does not recognise the operating system as
windows. Any ideas?

C:>gem install sqlite3-ruby
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for sqlite3.h… no

make
make: *** No rule to make target ruby.h', needed bysqlite3_api_wrap.o’. Stop
.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs