Installing Ruby on Oracle Enterprise Linux

I want to get some ruby working on a VM running OEL 6.1. The only
package manager seems to be yum and the VM isn’t configured with
knowledge of any yum repo containing a version of ruby. New to yum so I
could spend time trying to figure that out.

Or I could try installing from source. But I’m still new to Linux.

  1. How do I go about downloading the source file?

http://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.1.tar.gz

  1. How do I extract it?

On OEL 6.1

Or should i just give in and use one of the ruby managers like RVM?

It’s a VM so don’t have to worry about mucking things up.

thanks

p.s. I have only SSH access to the VM.

I’ve no experience with OEL, but to answer your concrete questions:

$ wget http://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.1.tar.gz
$ tar xzf ruby-2.2.1.tar.gz

should work on most linux boxes.

This will download and unpack the source into the directory ruby-2.2.1.
Then follow the readme file in the source.

Good luck!

Thank you Gunter. I shall give that a try and let you know how it goes.

This VM I am working with probably doesn’t have wget! lol.

We shall see.

Well, lucky for me, I have a copy of The Definitive Guide to GCC.

$ wget http://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.1.tar.gz
$ tar xzf ruby-2.2.1.tar.gz
should work on most linux boxes.

Indeed they did. both worked great. Thank you

Then I ran ./configure

And discovered that no build tools were installed on the VM. lol!

So it was back to yum. But I guess it was worth it because I did learn
something. More to follow.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs