Installing ruby 2.0 -- no checksum error

$ rvm install ruby-2.0.0-p0
Installing Ruby from source to: /Users/7stud/.rvm/rubies/ruby-2.0.0-p0,
this may take a while depending on your cpu(s)…

ruby-2.0.0-p0 - #downloading ruby-2.0.0-p0, this may take a while
depending on your connection…
There is no checksum for
http://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p0.tar.bz2’ or
‘ruby-2.0.0-p0.tar.bz2’, it’s not possible to validate it.
If you wish to continue with unverified download add ‘–verify-downloads
1’ after the command.

There has been an error while trying to fetch the source.
Halting the installation.
There has been an error fetching the ruby interpreter. Halting the
installation.

$ rvm -v
rvm 1.15.8 (master) by Wayne E. Seguin [email protected], Michal
Papis [email protected] [https://rvm.io/]

Mac OSX 10.6.8

Install latest rvm.

➜ ~ rvm -v

rvm 1.19.0 (master) by Wayne E. Seguin [email protected], Michal
Papis [email protected] [https://rvm.io/]

➜ ~ rvm list

rvm rubies

jruby-1.6.1 [ x86_64 ]
jruby-1.6.5 [ x86_64 ]
jruby-1.6.5.1 [ x86_64 ]
jruby-1.6.7.2 [ x86_64 ]
jruby-1.6.8 [ x86_64 ]
maglev-head [ x86_64 ]
ruby-1.8.7-p352 [ i686 ]
ruby-1.8.7-p357 [ i686 ]
ruby-1.8.7-p357-rg136 [ i686 ]
ruby-1.9.3-p0 [ x86_64 ]
ruby-1.9.3-p194 [ x86_64 ]
ruby-1.9.3-p392 [ x86_64 ]
=* ruby-2.0.0-p0 [ x86_64 ]

=> - current

=* - current && default

* - default

Julian

if you did rvm get head, it should install ruby 2.0 by default… :slight_smile:

Julian

I did $ rvm get stable, which from the rvm website seemed like the right
thing to do. However, if I had issued the command rvm get head, I
expect I would have gotten the same errors.

Well I did rvm get head and it worked for me is all.

Julian

Thanks for the response Jullian. Now there seems to be a ruby gems
problem:

===
Error running ‘env
GEM_PATH=/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/[email protected]:/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/[email protected]
GEM_HOME=/Users/7stud/.rvm/gems/ruby-2.0.0-p0
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d
/Users/7stud/.rvm/src/rubygems-2.0.3/setup.rb --verbose’,
please read /Users/7stud/.rvm/log/ruby-2.0.0-p0/rubygems.install.log
Installation of rubygems did not complete successfully.
Saving wrappers to ‘/Users/7stud/.rvm/wrappers/ruby-2.0.0-p0’…

ruby-2.0.0-p0 - #adjusting #shebangs for (gem irb erb ri rdoc testrb
rake).
ruby-2.0.0-p0 - #importing default gemsets, this may take
time…
Install of ruby-2.0.0-p0 - #complete

===

Here is what I did:

~/perl_programs$ rvm update
ERROR: rvm update has been removed. See ‘rvm get’ and rvm ‘rubygems’ CLI
API instead

~/perl_programs$ rvm get stable
% Total % Received % Xferd Average Speed Time Time Time
Current
Dload Upload Total Spent Left
Speed
100 13130 100 13130 0 0 5665 0 0:00:02 0:00:02 --:–:--
55872
Downloading RVM from wayneeseguin branch stable
bash: line 110: rvm_is_a_shell_function: command not found
% Total % Received % Xferd Average Speed Time Time Time
Current
Dload Upload Total Spent Left
Speed
100 3261k 100 3261k 0 0 229k 0 0:00:14 0:00:14 --:–:--
215k

Upgrading the RVM installation in /Users/7stud/.rvm/
RVM PATH line found in /Users/7stud/.bashrc /Users/7stud/.zshrc.
RVM sourcing line found in /Users/7stud/.bash_profile
/Users/7stud/.zlogin.

Upgrade Notes:

  • If you wish to get more default(global) gems installed, install RVM
    with this flag: --with-gems=“pry vagrant”
    this option is remembered, it’s enough to use it once.

  • Binary rubies are installed by default if available, you can read
    about it in help:
    rvm help install
    rvm help mount

  • The default umask for multi-user installation got extended to umask u=rwx,g=rwx,o=rx,
    comment it out to avoid automatic updates.

  • If you encounter any issues with a ruby ‘X’ your best bet is to:
    rvm get head && rvm reinstall X --debug

  • RVM will run ‘rvm requirements’ by default, to disable run:
    echo rvm_autolibs_flag=0 >> ~/.rvmrc

  • RVM will set first installed ruby as default and use it if run as
    function.
    To avoid this behavior either use full path to rvm binary or prefix
    it with command.

  • To update RVM loading code run ‘rvm get … --auto-dotfiles’

  • RVM will try automatically use available package manager, might
    require sudo,
    read more about it in rvm help autolibs

RVM: Shell scripts enabling management of multiple ruby environments.

RTFM: https://rvm.io/

HELP: http://webchat.freenode.net/?channels=rvm (#rvm on

irc.freenode.net)

Cheatsheet: http://cheat.errtheblog.com/s/rvm

Screencast: http://screencasts.org/episodes/how-to-use-rvm

In case of any issues run ‘rvm requirements’ or read ‘rvm notes’

Upgrade of RVM in /Users/7stud/.rvm/ is complete.

7stud,

Thank you for using RVM!

I sincerely hope that RVM helps to make your life easier and

more enjoyable!!!

~Wayne

RVM reloaded!

~/perl_programs$ rvm install ruby-2.0.0-p0
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.6/i386/ruby-2.0.0-p0.
Continuing with compilation. Please read ‘rvm mount’ to get more
information on binary rubies.
Installing requirements for osx, might require sudo password.
-bash: requirements_find_smf: command not found
Requested installation with homebrew libs, but homebrew is not
available.
RVM autolibs is now configured with mode ‘2’ => ‘check and stop if
missing’,
please run rvm autolibs enable to let RVM do it’s job or run and read
rvm autolibs [help]
or visit https://rvm.io/rvm/autolibs for more information.

~/perl_programs$ rvm autolibs enable
~/perl_programs$ rvm install ruby-2.0.0-p0
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.6/i386/ruby-2.0.0-p0.
Continuing with compilation. Please read ‘rvm mount’ to get more
information on binary rubies.
Installing requirements for osx, might require sudo password.
-bash: requirements_find_smf: command not found
Installing homebrew.
Initialized empty Git repository in /Users/7stud/.homebrew/.git/
remote: Counting objects: 107033, done.
remote: Compressing objects: 100% (44564/44564), done.
remote: Total 107033 (delta 75989), reused 89713 (delta 61542)
Receiving objects: 100% (107033/107033), 16.11 MiB | 229 KiB/s, done.
Resolving deltas: 100% (75989/75989), done.
From https://github.com/mxcl/homebrew

  • [new branch] gh-pages -> origin/gh-pages
  • [new branch] go -> origin/go
  • [new branch] master -> origin/master
  • [new branch] superwip -> origin/superwip
    HEAD is now at 04e7b94 sqlite 3.7.16.1
    Already up-to-date.
    Installing required packages: autoconf, automake, libtool, pkg-config,
    libyaml, readline, libxml2, libxslt, libksba, openssl,
    sqlite…
    Updating certificates in ‘/Users/7stud/.rvm/etc/openssl/cert.pem’.
    Doing /Users/7stud/.rvm/etc/openssl
    cert.pem => 33f86c5a.0
    Installing Ruby from source to: /Users/7stud/.rvm/rubies/ruby-2.0.0-p0,
    this may take a while depending on your cpu(s)…
    ruby-2.0.0-p0 - #downloading ruby-2.0.0-p0, this may take a while
    depending on your connection…
    ########################################################################
    100.0%
    ruby-2.0.0-p0 - #extracting ruby-2.0.0-p0 to
    /Users/7stud/.rvm/src/ruby-2.0.0-p0
    ruby-2.0.0-p0 - #extracted to /Users/7stud/.rvm/src/ruby-2.0.0-p0
    ruby-2.0.0-p0 -
    #configuring
    ruby-2.0.0-p0 -
    #compiling
    ruby-2.0.0-p0 - #installing

    Retrieving rubygems-2.0.3
    ########################################################################
    100.0%
    Extracting rubygems-2.0.3 …
    Removing old Rubygems files…
    Installing rubygems-2.0.3 for
    ruby-2.0.0-p0…
    Error running ‘env
    GEM_PATH=/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/[email protected]:/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/[email protected]
    GEM_HOME=/Users/7stud/.rvm/gems/ruby-2.0.0-p0
    /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d
    /Users/7stud/.rvm/src/rubygems-2.0.3/setup.rb --verbose’,
    please read /Users/7stud/.rvm/log/ruby-2.0.0-p0/rubygems.install.log
    Installation of rubygems did not complete successfully.
    Saving wrappers to ‘/Users/7stud/.rvm/wrappers/ruby-2.0.0-p0’…

ruby-2.0.0-p0 - #adjusting #shebangs for (gem irb erb ri rdoc testrb
rake).
ruby-2.0.0-p0 - #importing default gemsets, this may take
time…
Install of ruby-2.0.0-p0 - #complete
~/perl_programs$

Here’s the log file that the error message said to read:

[2013-03-31 00:52:28] /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby
current path: /Users/7stud/.rvm/src/rubygems-2.0.3
command(7): env
GEM_PATH=/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/[email protected]:/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/[email protected]
GEM_HOME=/Users/7stud/.rvm/gems/ruby-2.0.0-p0
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d
/Users/7stud/.rvm/src/rubygems-2.0.3/setup.rb --verbose
Exception LoadError' at /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/rubygems.rb:1073 - cannot load such file -- rubygems/defaults/operating_system ExceptionLoadError’ at
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/rubygems.rb:1082 -
cannot load such file – rubygems/defaults/ruby
mkdir -p /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0
mkdir -p /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin
install -c -m 0644 gauntlet_rubygems.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/gauntlet_rubygems.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems
install -c -m 0644 rubygems/available_set.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/available_set.rb
install -c -m 0644 rubygems/command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/command.rb
install -c -m 0644 rubygems/command_manager.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/command_manager.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands
install -c -m 0644 rubygems/commands/build_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/build_command.rb
install -c -m 0644 rubygems/commands/cert_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/cert_command.rb
install -c -m 0644 rubygems/commands/check_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/check_command.rb
install -c -m 0644 rubygems/commands/cleanup_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/cleanup_command.rb
install -c -m 0644 rubygems/commands/contents_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/contents_command.rb
install -c -m 0644 rubygems/commands/dependency_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/dependency_command.rb
install -c -m 0644 rubygems/commands/environment_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/environment_command.rb
install -c -m 0644 rubygems/commands/fetch_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/fetch_command.rb
install -c -m 0644 rubygems/commands/generate_index_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/generate_index_command.rb
install -c -m 0644 rubygems/commands/help_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/help_command.rb
install -c -m 0644 rubygems/commands/install_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/install_command.rb
install -c -m 0644 rubygems/commands/list_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/list_command.rb
install -c -m 0644 rubygems/commands/lock_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/lock_command.rb
install -c -m 0644 rubygems/commands/mirror_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/mirror_command.rb
install -c -m 0644 rubygems/commands/outdated_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/outdated_command.rb
install -c -m 0644 rubygems/commands/owner_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/owner_command.rb
install -c -m 0644 rubygems/commands/pristine_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/pristine_command.rb
install -c -m 0644 rubygems/commands/push_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/push_command.rb
install -c -m 0644 rubygems/commands/query_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/query_command.rb
install -c -m 0644 rubygems/commands/rdoc_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/rdoc_command.rb
install -c -m 0644 rubygems/commands/search_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/search_command.rb
install -c -m 0644 rubygems/commands/server_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/server_command.rb
install -c -m 0644 rubygems/commands/setup_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/setup_command.rb
install -c -m 0644 rubygems/commands/sources_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/sources_command.rb
install -c -m 0644 rubygems/commands/specification_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/specification_command.rb
install -c -m 0644 rubygems/commands/stale_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/stale_command.rb
install -c -m 0644 rubygems/commands/uninstall_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/uninstall_command.rb
install -c -m 0644 rubygems/commands/unpack_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/unpack_command.rb
install -c -m 0644 rubygems/commands/update_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/update_command.rb
install -c -m 0644 rubygems/commands/which_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/which_command.rb
install -c -m 0644 rubygems/commands/yank_command.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/yank_command.rb
install -c -m 0644 rubygems/compatibility.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/compatibility.rb
install -c -m 0644 rubygems/config_file.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/config_file.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext
install -c -m 0644 rubygems/core_ext/kernel_gem.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb
install -c -m 0644 rubygems/core_ext/kernel_require.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb
install -c -m 0644 rubygems/defaults.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/defaults.rb
install -c -m 0644 rubygems/dependency.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb
install -c -m 0644 rubygems/dependency_installer.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency_installer.rb
install -c -m 0644 rubygems/dependency_list.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency_list.rb
install -c -m 0644 rubygems/dependency_resolver.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency_resolver.rb
install -c -m 0644 rubygems/deprecate.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/deprecate.rb
install -c -m 0644 rubygems/doctor.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/doctor.rb
install -c -m 0644 rubygems/errors.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/errors.rb
install -c -m 0644 rubygems/exceptions.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/exceptions.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext
install -c -m 0644 rubygems/ext/builder.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/builder.rb
install -c -m 0644 rubygems/ext/cmake_builder.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/cmake_builder.rb
install -c -m 0644 rubygems/ext/configure_builder.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/configure_builder.rb
install -c -m 0644 rubygems/ext/ext_conf_builder.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/ext_conf_builder.rb
install -c -m 0644 rubygems/ext/rake_builder.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/rake_builder.rb
install -c -m 0644 rubygems/ext.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext.rb
install -c -m 0644 rubygems/gem_runner.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/gem_runner.rb
install -c -m 0644 rubygems/gemcutter_utilities.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/gemcutter_utilities.rb
install -c -m 0644 rubygems/indexer.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/indexer.rb
install -c -m 0644 rubygems/install_message.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/install_message.rb
install -c -m 0644 rubygems/install_update_options.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/install_update_options.rb
install -c -m 0644 rubygems/installer.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/installer.rb
install -c -m 0644 rubygems/installer_test_case.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/installer_test_case.rb
install -c -m 0644 rubygems/local_remote_options.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/local_remote_options.rb
install -c -m 0644 rubygems/mock_gem_ui.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/mock_gem_ui.rb
install -c -m 0644 rubygems/name_tuple.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/name_tuple.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package
install -c -m 0644 rubygems/package/digest_io.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/digest_io.rb
install -c -m 0644 rubygems/package/old.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/old.rb
install -c -m 0644 rubygems/package/tar_header.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_header.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_reader
install -c -m 0644 rubygems/package/tar_reader/entry.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_reader/entry.rb
install -c -m 0644 rubygems/package/tar_reader.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_reader.rb
install -c -m 0644 rubygems/package/tar_test_case.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_test_case.rb
install -c -m 0644 rubygems/package/tar_writer.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_writer.rb
install -c -m 0644 rubygems/package.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package.rb
install -c -m 0644 rubygems/package_task.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package_task.rb
install -c -m 0644 rubygems/path_support.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/path_support.rb
install -c -m 0644 rubygems/platform.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/platform.rb
install -c -m 0644 rubygems/psych_additions.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/psych_additions.rb
install -c -m 0644 rubygems/psych_tree.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/psych_tree.rb
install -c -m 0644 rubygems/rdoc.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/rdoc.rb
install -c -m 0644 rubygems/remote_fetcher.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/remote_fetcher.rb
install -c -m 0644 rubygems/request_set.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/request_set.rb
install -c -m 0644 rubygems/requirement.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/requirement.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security
install -c -m 0644 rubygems/security/policies.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/policies.rb
install -c -m 0644 rubygems/security/policy.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/policy.rb
install -c -m 0644 rubygems/security/signer.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/signer.rb
install -c -m 0644 rubygems/security/trust_dir.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/trust_dir.rb
install -c -m 0644 rubygems/security.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security.rb
install -c -m 0644 rubygems/server.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/server.rb
install -c -m 0644 rubygems/source.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source.rb
install -c -m 0644 rubygems/source_list.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source_list.rb
install -c -m 0644 rubygems/source_local.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source_local.rb
install -c -m 0644 rubygems/source_specific_file.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source_specific_file.rb
install -c -m 0644 rubygems/spec_fetcher.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/spec_fetcher.rb
install -c -m 0644 rubygems/specification.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb
install -c -m 0644 rubygems/syck_hack.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/syck_hack.rb
install -c -m 0644 rubygems/test_case.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/test_case.rb
install -c -m 0644 rubygems/test_utilities.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/test_utilities.rb
install -c -m 0644 rubygems/text.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/text.rb
install -c -m 0644 rubygems/uninstaller.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/uninstaller.rb
install -c -m 0644 rubygems/user_interaction.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/user_interaction.rb
install -c -m 0644 rubygems/validator.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/validator.rb
install -c -m 0644 rubygems/version.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/version.rb
install -c -m 0644 rubygems/version_option.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/version_option.rb
install -c -m 0644 rubygems.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems.rb
install -c -m 0644 ubygems.rb
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/ubygems.rb
mkdir -p
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs
install -c -m 0644 rubygems/ssl_certs/AddTrustExternalCARoot.pem
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/AddTrustExternalCARoot.pem
install -c -m 0644
rubygems/ssl_certs/Entrust_net-Secure-Server-Certification-Authority.pem
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/Entrust_net-Secure-Server-Certification-Authority.pem
install -c -m 0644 rubygems/ssl_certs/GeoTrust_Global_CA.pem
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/GeoTrust_Global_CA.pem
install -c -m 0644
rubygems/ssl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pem
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pem
install -c -m 0755
/var/folders/++/++iEr0qoGaimgUBsnNcijk+++TI/-Tmp-/gem.33469
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/gem
rm /var/folders/++/++iEr0qoGaimgUBsnNcijk+++TI/-Tmp-/gem.33469
ERROR: While executing gem … (NoMethodError)
undefined method `fu_stream_blksize’ for
#Gem::Commands::SetupCommand:0x00000101864280
Installing RubyGems
Installing gem executable

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs