Installing Ruby 2.0.0-p0 using Rbenv on Ubuntu 12.04.2 LTS

I am having a problem installing Ruby 2.0.0-p0 using rbenv install on
Ubuntu 12.04.2 LTS. I have clean version of Ubuntu 12.04.2 LTS running
on
Virtualbox.

I am getting this error and the build is failing. I think I read that
the
new RubyGems requires https.

I have tried rbenv install --with-openssl-dir=/usr/bin, but with no
success.

The Ruby openssl extension was not compiled. Missing the OpenSSL lib?

My suspicion is that ruby-build isn’t finding system openssl.

Would anyone know how to fix this problem?

Thanks in advance.

On Mon, Mar 11, 2013 at 5:09 PM, AmateurCoder
[email protected]wrote:

The Ruby openssl extension was not compiled. Missing the OpenSSL lib?

My suspicion is that ruby-build isn’t finding system openssl.

Would anyone know how to fix this problem?

Could you give us more hints on what you have done, please? Which steps
did
you follow? What errors did you get?

Start by telling us what you have when you type rbenv install 2.0.0-p0


Nicolas D.

On 11 March 2013 16:09, AmateurCoder [email protected]
wrote:

My suspicion is that ruby-build isn’t finding system openssl.

Would anyone know how to fix this problem?

I don’t know about rbenv (I use rvm) but for rails with rvm you need
sudo apt-get install openssl

In fact the full set you need when using ror with rvm is, I believe
build-essential bison openssl libreadline6 libreadline6-dev curl
git-core
zlib1g zlib1g-dev libssl-dev libyaml-dev libxml2-dev autoconf
libc6-dev ncurses-dev automake
libtool

Colin

I have rbenv and ruby-build installed.

$ rbenv install 2.0.0-p0

This downloads ruby 2.0.0-p0. It is not compiling and complains with
the
following error

BUILD FAILED

Inspect or clean up the working tree at
/tmp/ruby-build.20130311095340.2322
Results logged to /tmp/ruby-build.20130311095340.2322.log

Last 10 log lines:
installing default gems:
/home/scott/.rbenv/versions/2.0.0-p0/lib/ruby/gems/2.0.0 (build_info,
cache, doc, gems, specifications)
bigdecimal 1.2.0
io-console 0.4.2
json 1.7.7
minitest 4.3.2
psych 2.0.0
rake 0.9.6
rdoc 4.0.0
test-unit 2.0.0.0
The Ruby openssl extension was not compiled. Missing the OpenSSL lib?

OpenSSL is definitely installed on the system.

$ openssl version

OpenSSL 1.0.1 14 Mar 2012

It isn’t clear to me how to tell rbenv to use this version of OpenSSL?

On Mon, Mar 11, 2013 at 8:27 PM, AmateurCoder
[email protected]wrote:

Results logged to /tmp/ruby-build.20130311095340.2322.log
rake 0.9.6
rdoc 4.0.0
test-unit 2.0.0.0

The last 10 log lines do not help. Can you send post the log file if it
is
not too long or send it to me?

I am getting this error and the build is failing. I think I read that

For more options, visit https://groups.google.com/groups/opt_out.


Nicolas D.

Colin L. wrote in post #1101136:

On 11 March 2013 19:27, AmateurCoder [email protected]
wrote:

Results logged to /tmp/ruby-build.20130311095340.2322.log
rake 0.9.6

It isn’t clear to me how to tell rbenv to use this version of OpenSSL?

Is libssl-dev installed?

Colin

Thanks, installing libssl-dev worked for me (Rbenv on Ubuntu 12.04.2
LTS)
Micha

On 11 March 2013 19:27, AmateurCoder [email protected]
wrote:

Results logged to /tmp/ruby-build.20130311095340.2322.log
rake 0.9.6

It isn’t clear to me how to tell rbenv to use this version of OpenSSL?

Is libssl-dev installed?

Colin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs