Installing Ruby 1.9.2 on Win7

Hi,
I’m a total noob to Ruby and am following the pick axe book and
installing Ruby for the first time using the OneClick installer. I want
to us RoR 3.0 and it gives me errors with Ruby 1.9.1 and compatibility.
I was reading that you can use rvm to install Ruby versions but that
appears to only be for unix? What’s the best way to install Ruby
1.9.2rc2 on my Windows7 machine?
thanks!
Bill C.

Bill C. wrote:

Hi,
I’m a total noob to Ruby and am following the pick axe book and
installing Ruby for the first time using the OneClick installer. I want
to us RoR 3.0 and it gives me errors with Ruby 1.9.1 and compatibility.
I was reading that you can use rvm to install Ruby versions but that
appears to only be for unix? What’s the best way to install Ruby
1.9.2rc2 on my Windows7 machine?

Not answering your question directly, but RoR 3.0 should also be
compatible with ruby 1.8.7.

What’s the best way to install Ruby

1.9.2rc2 on my Windows7 machine?

http://rubyinstaller.org/

click on downloads, look for 1.9.2

Brian C. wrote:

Bill C. wrote:

Hi,
I’m a total noob to Ruby and am following the pick axe book and
installing Ruby for the first time using the OneClick installer. I want
to us RoR 3.0 and it gives me errors with Ruby 1.9.1 and compatibility.
I was reading that you can use rvm to install Ruby versions but that
appears to only be for unix? What’s the best way to install Ruby
1.9.2rc2 on my Windows7 machine?

Not answering your question directly, but RoR 3.0 should also be
compatible with ruby 1.8.7.

Brian,

Thanks! The book had recommended using at least 1.9.1 but there seems to
be alot of issues with that version so I thought I’d try to figure out
how to use the 1.9.2 that others have said solve many of those problems.
regards,
Bill C.

Bill C. wrote:

Thanks! The book had recommended using at least 1.9.1 but there seems to
be alot of issues with that version so I thought I’d try to figure out
how to use the 1.9.2 that others have said solve many of those problems.

ruby 1.9.x is a fundamentally different language to 1.8.x, both in its
implementation (YARV engine) and in its core behaviour (especially
Strings which are totally different). I’m afraid the “minor” point
revision is highly misleading.

Personally I much prefer the ruby 1.8 language, and that’s what I’m
sticking with. This is not an opinion shared by the majority here, but
it’s something you’ll have to make your own mind up about.

If Rails ever goes 1.9-only, then I’ll be dropping Rails.

Regards,

Brian.

Roger P. wrote:

What’s the best way to install Ruby

1.9.2rc2 on my Windows7 machine?

http://rubyinstaller.org/

click on downloads, look for 1.9.2

Thanks Roger…

There isn’t an installer for 1.9.2rc2. It’s marked as Experimental. I
can download it but not sure what to do after that.

regards,
Bill C.

There isn’t an installer for 1.9.2rc2. It’s marked as Experimental. I
can download it but not sure what to do after that.

unzip it using 7 zip, cd into the “bin” folder, run ruby from there. Or
add the bin folder to your path.

On Aug 2, 10:37 am, Bill C. [email protected] wrote:

There isn’t an installer for 1.9.2rc2. It’s marked as Experimental. I
can download it but not sure what to do after that.

You need 7-zip to extract that package.

You can extract it to any directory and after append the bin directory
to the PATH.

If what I’m saying is too complicated (or have no idea what all that
means) then use 1.8.7 from the installers.

Roger P. wrote:

There isn’t an installer for 1.9.2rc2. It’s marked as Experimental. I
can download it but not sure what to do after that.

unzip it using 7 zip, cd into the “bin” folder, run ruby from there. Or
add the bin folder to your path.

Roger,
Makes sense - thanks!
regards,
Bill C.

Luis L. wrote:

On Aug 2, 10:37�am, Bill C. [email protected] wrote:

There isn’t an installer for 1.9.2rc2. It’s marked as Experimental. I
can download it but not sure what to do after that.

You need 7-zip to extract that package.

You can extract it to any directory and after append the bin directory
to the PATH.

If what I’m saying is too complicated (or have no idea what all that
means) then use 1.8.7 from the installers.

Hi Luis,
Makes perfect sense. Thanks!
regards,
Bill C.

Brian C. wrote:

Bill C. wrote:

Thanks! The book had recommended using at least 1.9.1 but there seems to
be alot of issues with that version so I thought I’d try to figure out
how to use the 1.9.2 that others have said solve many of those problems.

ruby 1.9.x is a fundamentally different language to 1.8.x, both in its
implementation (YARV engine) and in its core behaviour (especially
Strings which are totally different). I’m afraid the “minor” point
revision is highly misleading.

Personally I much prefer the ruby 1.8 language, and that’s what I’m
sticking with. This is not an opinion shared by the majority here, but
it’s something you’ll have to make your own mind up about.

If Rails ever goes 1.9-only, then I’ll be dropping Rails.

Regards,

Brian.

Brian,
Good insight - I hadn’t thought about this part at all. Thanks for the
thoughts on this.
regards,
Bill

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs