Installing RMagick on CentOS 5

I’m have a very big trouble with my project.

I install RMagick on Centos, and catch error:

I use RVM + ruby 1.9.3

[[email protected] ~]$ gem install rmagick
Building native extensions. This could take a while…
ERROR: Error installing rmagick:
ERROR: Failed to build gem native extension.

    /home/kastet/.rvm/rubies/ruby-1.9.3-p0/bin/ruby extconf.rb

checking for Ruby version >= 1.8.5… yes
extconf.rb:128: Use RbConfig instead of obsolete and deprecated Config.
checking for gcc… yes
checking for Magick-config… yes
checking for ImageMagick version >= 6.4.9… yes
checking for HDRI disabled version of ImageMagick… yes
checking for stdint.h… *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
try_do': The compiler failed to generate an executable file. (RuntimeError) You have to install development tools first. from /home/kastet/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/1.9.1/mkmf.rb:506:intry_cpp’
block in have_header' from /home/kastet/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/1.9.1/mkmf.rb:790:inblock in checking_for’
block (2 levels) in postpone' from /home/kastet/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/1.9.1/mkmf.rb:254:inopen’
block in postpone' from /home/kastet/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/1.9.1/mkmf.rb:254:inopen’
postpone' from /home/kastet/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/1.9.1/mkmf.rb:789:inchecking_for’
have_header' from extconf.rb:193:in

Gem files will remain installed in
/home/kastet/.rvm/gems/ruby-1.9.3-p0/gems/rmagick-2.13.1 for inspection.
Results logged to

I try to find solution in other web, but no solutions with stdint.h not

Please help, Dmitriy

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs