Installing rails

I am completely new to ruby and to rails, but have brought a book Agile
Web D. with rails. I have sucessfully installed ruby, that
went fine. then decided to install rails, so went to cmd prompt on my
laptop and typed c:/ gem install rails --include dependancies
then pressed return. the first time i was not connected to the
internet, and it complained, but then I connected to the internet and
issued the same command again.
rails 1.0.0 installed sucessfully as did rake 0.7.0, activesupport
1.2.5, activerecord 1.13.2, actionpack 1.11.2, actionmailer 1.1.5 and
then it said installing RDoc documentation for rake-0.7.0…
installing RDoc documentation for
installing RDoc documentation for
installing RDoc documentation for
installing RDoc documentation for
installing RDoc documentation for
Localgem file not found: dependancies*.gem
Attempting remote installation of ‘dependancies’
ERROR: while executing gem … Gem::GemNotFoundException
Could not find dependancies <> 0> in the respository

I wonder whats gone wrong, can anyone help me please, is it that the
connection to the server that failed or is it that something is corrupt
or missing on the server, or do i just need to do it again?
What does the error actually mean in plain language please
If anyone can help I would be very graitfull indeed

Julian in Reading Berkshire

I would try again – no great cost there, right,
then you will know if it installs if you try again.

Then I would look at your system, — you don’t say what it is – and I
would look for alternatives. When I installed rails there were various
ways of doing it. I looked into locomotive…

From julian
My operation system is windows XP Home with service pack 2 and it is
running on a fujitsu siemens amilo pro lap top.
It looks like it almost did everythink ok, it is just the the bit after
the Attempting remote installation of ‘dependancies’ when the error was
generated, straingely it does not specifically say which dependancies
it could not find.
What are the dependancies that it should find and install, are these
files that the ruby interpreter needs or files that rails needs? Sorry
if the questions are a bit basic but I am very new to this and do want
to learn, but it will I am sure take a while.

which version of gem do you h ave, is it the latest?

I found
gem install rails --include-dependencies

(If this command gives you an error, you do not have the latest version
of gems installed. Run “gem -v”, it should be 0.8.10. If it’s an
earlier version, I recommend to reinstall the newest package - see
beginning of the tutorial).

tar very much for your help and responce, I have ran gem -v and it
reports 0.8.10, I belive that is the lattest version of gem. Therefore
I will try the link that you suggest at the website,
and will post up what happens,

Very much appreciate your time and help

also check your spelling of dependencies. The site spelling seems
different from yours

spelling dependencies incorrectly was a silly mistake on my part and I
believe that the correct spelling of the word is dependencies, and
having used the correct spelling and the line;
gem install rails --include dependencies
I am getting the error about
Attempting local installation of ‘rails’
ERROR: Error installing gem rails[.gem]: No metadata found!
This is a diffrent error of course, but I do not know what is causing
it yet…/

I have had a look at the article mentioned above and I then opened up
my cmd window, and navigated into the ruby bin directory.
I think when i issued the command to install rails I spelt dependencies
with an a after depend
I also notice that in the article it says to type in
gem install rails --include-dependencies
in other words there is a - inbetween the word include and
Anyway i do not know if it should be:
gem install rails --include dependencies or
gem include rails --include-dependencies

Anyway I have tried both and got this message:
Attempting local installation of ‘rails’
ERROR:Error installing gem rails[.gem]: No metadata found!

I assume from this message that the gem program is trying to attempt
to install rails from a local source i.e. already on my hard disk

But I think that I need to get the files to install rails and it
dependancies from the web site, so

  1. I don’t know why I am getting this new error message
  2. and I do not know why it is looking for metadata

mm. it is confussing I am afraid, but your help is very usefull and
helpful, and any further idears are v welcome indeed. ta Julian


RubyGems is a system that aims to provide the following (it is still in
A development framework that allows developers working on pure-Ruby
projects to packages those projects into a single file that contains
their source files as well as metadata describing the project. This
metadata includes the name for the project, the author’s name, a
category, a version, a description, and even dependencies the project
Also, locale metadata as in: lang=en, country=us, charset=us-ascii
[HoracioLopez vruz]

it would be install, include is for ruby programs I would think.
see if any of this might be your problem. Do you have several ruby
installed? On the
mac for example, Ruby comes pre installed.

how about this? could that help? says it is for windows
how about this
It is not up to date, apparently some directory has changed, but it
shows how
someone thinks it should work.

You could just use Instant Rails:


How about rebooting and trying the beta version 0.8.11?

If I was to use instant would this not try to
install a copy or apache webserver on my computer, and would this not
conflict with the current apache server living in c:/Program Files.
Yes I do not think you can have two apache web servers on the same
computer and expect it to work properly as this would not make any
sence configuration wise, where would you put you finished web pages in
which web server?
surely this would not work would it ??
Kind regards julian

As always ta very much indeed your help and time and persistance are
very welcome. I have tried updating the gems and have issued the
command from C:\ruby\bin
gem update --system.
That worked absolutely fine, and now I have some new sparkling gems! it
Ruby gem system data updated.
so i will issue gem -v
and i get 0.8.11 as expected. So I have updated from gems 0.8.10 to
0.8.11. that is fine.
The link you mention :
is this for installing ruby and rails on a shell in otherwords on a
unix opperating system, I think it is unix opperating systems that have
a shell as such normally used for writting so called shell programs, I
am conserned that this may not work on MS Windows XP Home?
Of course as in php and python and perl and many languages we / you
find many refrences to unix or linux, and I think may be I need to
understand what’s going to work in Unix and what’s going to work in
windows, from the point of view of installation.
i have only updated from gems 0.8.10 to 0.8.11, and I have ruby version
I am very sorry I do not understand what is local metadata and why /
where would the installation process be looking for it? I am willing to
try as many things out as it takes but am very nervous of packages that
install ruby rails, apache, mysql etc etc all at once!?
I have on my computer already apache configured to use php 4.4.1 and
mysql 4.1.16 working correctly.
i notice in the control panel / add /remove programs there is a ruby
uninstaller, so I guessI could uninstall ruby and start again, but this
raises questions where are all rthe other programs that support ruby
like rake, activesupport etc etc, bassically all the other ones that
were reported as having been installed successfully.
Thanks for you help receintly very much appreciated the battle to
install rails goes on… at the moment… and will continue untill we
have a real solution that works. I do not give up!!!

The answer comes to those who are perssitant and do not give up. I have
it working apparently, what I did was to use the program inside the
ruby directory to uninstall ruby. Then I installed ruby again version
1.8.2, then I updated the gems and got some nice glitering new ones
from 0.8.10 to 0.8.11, then I tried installing rails once more the same
line from C:\ruby\bin
gem install rails --include-dependencies
and hit return. You must be connected to thre internet when you do
this cause the gem program goes and installs quite a few things, rails
rake activesupport active record actionpack actionmailer
actionwebservice plus documentation for all six, and then after a tence
wait the curser goes to C:\ruby\bin
And no messages of error, everything installed from the webserver
straight down the line.
The answer is if you do not succced then un install ruby, reinstall
ruby, update your gems and install rails again.
Clearly there is some merit in doing the install of rails many times
until it damn well works…
Now we move on to how to use ruby and rails, but not just yet as I must
do some work on my web design course, but thank you very much indeed
for all your time patience and help

what about playing with version?
gem install rails --version=1.0.0't-install-rails%2C-instructions-in-the-book-are-wrong…-t990651.html#a2568356

When I installed locomotove, it did not replace apache, database etc.
It was just an application of its own, which acted like rails.

I agree that it would be better if you could get the normal way
working, but if instant rails work, at least you would be banging your
head on rails, not on xp and installers.

good for you! that’s the spirit, and thank you for posting back so if
else has the problem, they will find how you got out of your fix.

I prefer
you get the latest post on top, how many responses, search …

The ruby list is sometimes more responsive than the rails list, but
here do prefer that rails question be posted on the rails list.

You can tell Instant Rails not to start its copy of apache.


On Mar 25, 2006, at 12:38 PM, julian wrote:

Now we move on to how to use ruby and rails, but not just yet as I
do some work on my web design course, but thank you very much indeed
for all your time patience and help

Glad to hear that you got it working Julian…

For future Rails-specific problems, I think you’ll find that you’re
likely to get a quicker and more accurate response on the Ruby on
Rails specific mailing list.

For subscription and posting information, please visit the Rails
mailing list page at:


This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs