Installing rails on lucid lynx

I am getting the following error when I try to install rails on lucid
lynx :-

mark@mark-laptop:~/code/ruby$ sudo gem install rails
ERROR: Error installing rails:
i18n requires RubyGems version >= 1.3.6

I have installed RubyGems1.9.1, but it seems that “gem” is still at
version 1.3.5 :-

mark@mark-laptop:~/code/ruby$ /usr/bin/gem1.9.1 -v

I have the following version of Ruby :-

mark@mark-laptop:~/code/ruby$ ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [i486-linux]

Any idea what I am doing wrong?


Hi Mark,

Apparently you can only update ruby gems from the repositories. What I
have done was install it from source. Just grab the source and install
it. It will overwrite the existing one.

I don’t know if anyone else has another solution, but that is the one I

Hope that helps.



Additionally, Mark, don’t use ruby 1.9.1 with rails: it’s buggy.and it’s
recommended, as mentioned on RoR home page. Consider compiling ruby from
source, either version 1.8.7 or 1.9.2. Follow the step by step
from Ruby official site if in doubt. Install RubyGems manually
afterwards by
running the install script form their official page: a third step, just install rails
a gem. I’,m also using Ubuntu as a development environment and I
you to keep up-to-date on your tools by following this install path. The
repositories are lagging behind.