Installing Rails 2.0

Help! I cant install Rails 2.0. Can anybody help me?

[email protected]:~/zeugs/rails/blog$ ruby script/server
Missing the Rails 2.0 gem. Please gem install -v=2.0 rails, update
your RAILS_GEM_VERSION setting in config/environment.rb for the Rails
version you do have installed, or comment out RAILS_GEM_VERSION to use
the latest version installed.
[email protected]:~/zeugs/rails/blog$ sudo gem install -v=2.0 rails
[sudo] password for kb1:
ERROR: Error installing rails:
rails requires activeresource (= 2.0.0, runtime)

But now what?
I uninstall rails 2.1 and actionmailer, actionpack etc. in version 2.1 -
but this dont solve my problem.

[email protected]:~/zeugs/rails/blog$ sudo gem list

*** LOCAL GEMS ***

actionmailer (2.0.0)
actionpack (2.0.0)
activerecord (2.0.0)
activesupport (2.0.0)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
mongrel (1.1.5)
mysql (2.7)
rake (0.8.1)
sqlite3-ruby (1.2.2)
[email protected]:~/zeugs/rails/blog$ sudo gem install -v=2.0 rails
ERROR: Error installing rails:
rails requires activeresource (= 2.0.0, runtime)

what can i do?
Using Ubuntu 32Bit. Using Ruby from synaptics and installed rubygems by
hand through the tar.gz package.

solved it by installing rails 2.0.2!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs