Installing problem


#1

Hello guys,
I’ve used rails engines in the past, but now I was configuring a new
system and I can’t get the engines to work, when I try to generate the
migrations for the plugins with the command:
ruby script/generate plugin_migration I have the following error:

clustermedia-labss-macbook-pro:teste we$ ruby script/generate
plugin_migration
/Library/Ruby/Gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:263:in
load_missing_constant': uninitialized constant Rails::Plugin (NameError) from /Library/Ruby/Gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:452:inconst_missing’
from
./script/…/config/…/vendor/plugins/engines/lib/engines/plugin.rb:15
from
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
/Library/Ruby/Gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
require' from /Library/Ruby/Gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:innew_constants_in’
from
/Library/Ruby/Gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
require' from ./script/../config/../vendor/plugins/engines/lib/engines.rb:2 ... 25 levels... from /Library/Ruby/Gems/1.8/gems/rails-1.2.3/lib/commands/generate.rb:1 from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from script/generate:3

I’ve tried with many many differente rails versions (from 1.1.6 to
1.2.5) and I always get this error… any ideas ?

tks,
Ze Maria