Installing gr-ettus

Hi,
I’m trying to install gr-ettus on an E310.
I previously installed a new version of UHD (to support RFNoC) in the
directory /opt/uhd
I would like to install gr-ettus into the existing version of gnuradio
that
is installed.

Inside the build directory of gr-ettus, when I type “cmake …/” I get
the
following message and error:
– Found UHD: /usr/lib/libuhd.so
CMake Error at CMakeLists.txt:108 (message):
RFNoC not found.

When I had installed UHD, I followed the steps in [1], and made sure
that
the new libuhd.so was in my LD_LIBRARY_PATH and I added the new path to
/etc/ld.so.conf; however, when I ran ldconfig I got the following error:
ldconfig: /usr/lib/libstdc++.so.6.0.20-gdb.py is not an ELF file - it
has
the wrong magic bytes at the start.
I had ignored that error, partly because I didn’t understand it, and
partly
because I had already updated the LD_LIBRARY_PATH variable. Was it a
mistake to ignore it?

I welcome any advice on installing gnuradio out-of-tree modules (such as
gr-ettus mentioned in [2]), and advice on managing different versions of
UHD on the same system. I can’t seem to get the gr-ettus installation
to
look at the new version of UHD. Note: I am using the E310 Dizzy build
[3].

Thanks!
-ben

[1] http://files.ettus.com/manual/page_build_guide.html
[2] https://github.com/EttusResearch/uhd/wiki/RFNoC:-Getting-Started
[3] http://files.ettus.com/e3xx_images/beta/dizzy-test/

Ben,

you must use the right branch of UHD (which I know you’ve been using).
For cross-compiling, you need to make sure that all the CMake vars
starting with UHD_ are correctly set.

Are you using our SDK? If yes, it’s probably pointing to the SDK’s
default UHD.

M

Martin,
I am not using the SDK. The steps I have taken so far:
Created a new SD card from the dizzy dev image found at [1].
Followed the steps at [2] to clone the RFNoC git repository, switch to
rfnoc-devel branch, build it, install it to /opt/uhd
My next challenge was to install the gr-ettus OOT module to be able to
use
the RFNoC blocks in GRC.
The dizzy image already had a previous install of UHD and GNU RADIO.
For
RFNoC I installed a new UHD with the RFNoC branch. I was hoping to add
gr-ettus to the existing GNU RADIO install, to simplify things.
I am doing all of this on the E310. Is this the right way to do it? I
assumed that I didn’t need the SDK because I already had an SD image
built.
Thanks,
-ben
[1] http://files.ettus.com/e3xx_images/beta/dizzy-test/
[2] https://github.com/EttusResearch/uhd/wiki/RFNoC:-Getting-Started

On Fri, Mar 13, 2015 at 2:12 PM, Martin B. [email protected]

I didn’t realize you were doing on this on the device. If you have all
the PATHs set up correctly, you should be good, but it looks like you’re
using the default UHD. Have a look at your CMake cache (in gr-ettus) and
see where the UHD_* vars point to. They’re ‘advanced’ vars, in case you
can’t see them immediately.

Cheers,
M

And you must have rfnoc-devel branch of UHD installed. This is not on
the default image.

M

On 03/13/2015 05:16 PM, Martin B. wrote:

And you must have rfnoc-devel branch of UHD installed. This is not on
the default image.

Somewhere we have a toolchain file for cmake to build natively?
Otherwise the default flags are for older arms and no neon.

Philip

I run gr-ettus on E300 all the time using the GNU Radio toolchain file.
You have to set UHD_INCLUDE_DIRS and UHD_LIBRARIES, though.

M

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs