Installing flickr.rb on Dreamhost Error - HELP

I tried to install flickr.rb on my Dreamhost server, and I got an error.
This is what I did to install it:

$> gem install flickr

I’m not sure if there are any other parameters… does anyone know why I
got errors when trying to install this? What does it mean when it asks
“Install required dependency xml-simple?”

By the way, here’s the results:

[myserver]$ gem install flickr
Attempting local installation of ‘flickr’
Local gem file not found: flickr*.gem
Attempting remote installation of ‘flickr’
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency xml-simple? [Yn] y
ERROR: While executing gem … (Errno::EACCES)
Permission denied -
/usr/lib/ruby/gems/1.8/cache/xml-simple-1.0.9.gem

ry an wrote:

I tried to install flickr.rb on my Dreamhost server, and I got an error.
This is what I did to install it:

$> gem install flickr

ERROR: While executing gem … (Errno::EACCES)
Permission denied -
/usr/lib/ruby/gems/1.8/cache/xml-simple-1.0.9.gem

You need to run gem command under sudo

sudo gem install flickr

But I guess you have no permissions to do it on shared host. Ask you
administrators then.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs