Installing datebox_engine


#1

Hi,

I want to install date picker from datebox.inimit.com.

$ ruby script/plugin install datebox_engine
Plugin not found: datebox_engine

So I browse the website and download the universal file. It is in zip
format. I extract it and here is the content:
calendar-blue2.css calendar-green.css calendar-system.css
calendar-win2k-2.css dateparse.js lang
calendar-blue.css calendar-setup_stripped.js calendar-tas.css
calendar-win2k-cold-1.css iconCalendar.gif skins
calendar-brown.css calendar_stripped.js calendar-win2k-1.css
calendar-win2k-cold-2.css index.html

How do I install this into my application?

Thank you.


#2

On 2/18/06, Akbar removed_email_address@domain.invalid wrote:

calendar-win2k-2.css dateparse.js lang
calendar-blue.css calendar-setup_stripped.js calendar-tas.css
calendar-win2k-cold-1.css iconCalendar.gif skins
calendar-brown.css calendar_stripped.js calendar-win2k-1.css
calendar-win2k-cold-2.css index.html

How do I install this into my application?

Thank you.

Akbar,

I think the datebox_engine is still slightly bleeding edge.

I got it working yesterday in my app but it took some persistence.

The release engine_plugin (1.0.6) does not support the datebox_engine.

I had to install the engine_plugin from the trunk via svn

See http://www.ruby-forum.com/topic/54572#new for more details on trunk

I was able to install the datebox engine via “ruby script/plugin
install datebox_engine”. Not sure why that is not working for you.
You may have to do a “ruby script/plugin discover” first.

Once I followed the readme and got it basically working I still had
trouble getting it to update my database field. I also had trouble
getting multiple dateboxes on a single form. I solved my issue and
posted about it at:

http://www.ruby-forum.com/topic/54928#new

See the last (4th) entry in the thread.

HTH
Greg

Greg F.
The Norcross Group
Forensics for the 21st Century