Installing an old version of rails with 1.9.1

Hello,

I am running Ruby 1.9.1 and Rails 2.3.2 and need a copy of Rails 2.3.0
to do some testing on a plugin. I tried

sudo gem install -v 2.3.0 rails

But I got the following error:

ERROR: could not find gem rails locally or in a repository

Also I tried to download the v2.3.0 tag from github, but I didn’t know
what to do after that, cuz there is no gemspec in the top level
directory.

Does anybody know how to do this?

Thank you,
David :slight_smile:

On Sat, Mar 28, 2009 at 8:04 PM, David B.
[email protected]wrote:

ERROR: could not find gem rails locally or in a repository

Also I tried to download the v2.3.0 tag from github, but I didn’t know
what to do after that, cuz there is no gemspec in the top level
directory.

Does anybody know how to do this?

Thank you,
David :slight_smile:

Actually, Rails 2.3.0 isn’t a official release of Rails. However, it
was
the first release candidate
of Rails 2.3 and the second release candidate was Rails 2.3.1. The
first
official release of Rails 2.3
was Rails 2.3.2. Thus, I would highly recommend that you use that as
the
target for testing the plugin.

Good luck,

-Conrad

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs