Installazione rails fallita


#1

Sulla mia macchina ho installato 1.8.6-25 con l’one-click installer per
Windows, quindi ho cercato di installare rails, usando il comando:

gem install rails --include-dependencies

ma è andato in errore con il seguente messaggio:

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Bad file descriptor - connect(2)(Errno::EBADF)

Per dare qualche indizio, preciso che la macchina e’ su una rete ed
accede regolarmente ad Internet via un proxy ed un firewall.

Il problema e’ legato al proxy e/o al firewall?
Qualcuno può darmi una mano?
Grazie


#2

pino wrote:

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Bad file descriptor - connect(2)(Errno::EBADF)

Sembra che non riesca ad accedere al gem server, ma forse e’ un problema
diffuso (io in questo momento dalla mia ADSL Telecom non riesco ad
arrivare a quasi nessun sito US).

ciao,
Luca

Web: http://spazidigitali.com - http://thetyper.com
Email mailto://removed_email_address@domain.invalid
Skype callto://l.mearelli


#3

Luca M. wrote:

pino wrote:

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
Bad file descriptor - connect(2)(Errno::EBADF)

Sembra che non riesca ad accedere al gem server, ma forse e’ un problema
diffuso (io in questo momento dalla mia ADSL Telecom non riesco ad
arrivare a quasi nessun sito US).

ciao,
Luca

Web: http://spazidigitali.com - http://thetyper.com
Email mailto://removed_email_address@domain.invalid
Skype callto://l.mearelli

Il punto e’ che soli 2 giorni fa, da casa (quindi senza alcun proxy e
firewall) tutto e’ funzionato perfettamente…

D’altra parte, conosco cosi’ poco l’accoppiata ruby/gem (almeno per ora)
da non essere riuscito a capire in breve tempo il problema…

Cerca e ricerca… EUREKA!!!

Ho settato sulla mia macchina una variabile d’ambie_nte http_proxy sulla
mia macchina, nel modo consueto:

set http_proxy=http://xx.xx.xx.xx:yyyy

dove xx.xx.xx.xx e’ l’indirizzo del proxy server e yyyy la porta del
proxy, quindi ho rieseguito dalla stessa linea di comando (e quindi con
la
variabile http_proxy settata):

gem install rails --include-dependencies

e tutto ha funzionato alla perfezione!!!

However, grazie per la’ttenzione che mi hai dedicato
:wink:


#4

Ho settato sulla mia macchina una variabile d’ambie_nte http_proxy sulla
mia macchina, nel modo consueto:

set http_proxy=http://xx.xx.xx.xx:yyyy

dove xx.xx.xx.xx e’ l’indirizzo del proxy server e yyyy la porta del
proxy, quindi ho rieseguito dalla stessa linea di comando (e quindi con
la
variabile http_proxy settata):

gem install rails --include-dependencies

e tutto ha funzionato alla perfezione!!!

However, grazie per la’ttenzione che mi hai dedicato
:wink:

ho dovuto scrivere ambie_nte perche’ senza l’undercore il mio post
veniva riconosciuto come spam :frowning: