Installazione di passenger (mod_rails)


#1

Ciao a tutti!

Sto muovendo i primi passi sul deploy di un’applicazione rails.
Ho scelto di utilizzare Passanger come modulo di Apache.

Ho installato il tutto su ubuntu server 8.04 seguendo questa guida ben
fatta:
http://www.sysadminschronicles.com/2008/5/6/ubuntu-8-04-rails-server-using-passenger

Ho caricato la mia applicazione ma quando punto il browser verso
l’indirizzo del mio server ciò che ottengo è la lista dei file che ho
nella cartella ‘public’ della mia applicazione.

Ho verificato le varie impostazioni e riavviato più volte sia apache che
l’applicazione ma ottengo sempre il contenuto di ‘public’.

Help!

Grazie!


#2

Alle martedì 07 ottobre 2008, Enrico B. ha scritto:

Ho caricato la mia applicazione ma quando punto il browser verso
l’indirizzo del mio server ciò che ottengo è la lista dei file che ho
nella cartella ‘public’ della mia applicazione.

Ho verificato le varie impostazioni e riavviato più volte sia apache che
l’applicazione ma ottengo sempre il contenuto di ‘public’.

Help!

Grazie!

Due suggerimenti:

  • verifica di aver caricato il modulo passenger nei moduli apache e che
    sia
    in esecuzione. Se non ricordo male non te lo fa lo automaticamente lo
    script
    di installazione
  • verifica la configurazione del virtual host
    Ciao
    Giovanni

#3

Giovanni N. wrote:

Due suggerimenti:

  • verifica di aver caricato il modulo passenger nei moduli apache e che
    sia
    in esecuzione. Se non ricordo male non te lo fa lo automaticamente lo
    script
    di installazione
  • verifica la configurazione del virtual host
    Ciao
    Giovanni

Ho caricato il modulo di passenger inserendo questo codice in
/etc/apache2/apache2.conf

LoadModule passenger_module
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.3/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/passenger-2.0.3
PassengerRuby /usr/bin/ruby1.8

NameVirtualHost *:80

e questa è la configurazione del virtual host

<VirtualHost *:80>
ServerName test.myapp
RailsEnv development
DocumentRoot /var/rails/myapp/public

Il modulo sembra installato correttamente ma non riconosce
l’applicazione a cui deve puntare.


#4

prova a dare un’occhiata al file error.log di apache, giusto per esser
sicuri che non sia un problema di web server. Solitamente sta sotto
/var/log/apache2 …

2008/10/7 Enrico B. removed_email_address@domain.invalid


#5

Enrico B. wrote:

Roberto D. wrote:

prova a dare un’occhiata al file error.log di apache, giusto per esser
sicuri che non sia un problema di web server. Solitamente sta sotto
/var/log/apache2 …

Risolto!!

Effettivamente avevo indicato una ‘PassengerRoot’ errata ora è tutto ok!

Grazie mille Roberto, guardando i log ho risolto il tutto!

Enrico


#6

Roberto D. wrote:

prova a dare un’occhiata al file error.log di apache, giusto per esser
sicuri che non sia un problema di web server. Solitamente sta sotto
/var/log/apache2 …

2008/10/7 Enrico B. removed_email_address@domain.invalid

Effettivamente passenger non funziona questo è il logo di errore:

[Tue Oct 07 15:57:40 2008] [error] *** Passenger could not be
initialized because of this error: The Passenger spawn server script,
‘/usr/lib/ruby/gems/1.8/passenger-2.0.3/lib/passenger/passenger-spawn-server’,
does not exist. Please check whether the ‘PassengerRoot’ option is
specified correctly.

Qualche suggerimento?

Grazie mille per l’aiuto, sei molto gentile!

Enrico