Installation problems, Radiant 0.63 fresh install

Hi,

I’ve tried Googling for a solution and reading through the tutorials,
how to’s etc. but to no avail, it seems that I’ve a rare sort of
problem.

I have Ruby, Rails and Radiant (+MySQL) installed on a Ubuntu 7,04
desktop computer, Rails and Radiant were successfully installed
through gems.

For some reason the command Radiant cannot be found - as if some path
statement was missing, the same applies to rake as well.

Following these instructions:
"Once you have the gem installed, use the “radiant” command to create
a new project:

% radiant --database [mysql|postresql|sqlite3] path/to/project"

produces the following error (the same with sudo …):
main:~$ radiant
bash: radiant: command not found

Any ideas what should be added and where and how? I’m hoping I could
get to familiarize myself with Radiant before considering it for some
projects.

Kindest regards,

Niko Kotiniemi

Hi Niko,

The path to radiant should be /usr/bin/radiant. Does that file exist?
If it does there is likely something wrong with your $PATH
environment variable in your shell. What is the output of echo $PATH?

-teyo

Niko,

I had the same issue on Debian and it was a pathing problem. What you
need
to do is open up your .bashrc and add the path to the Radiant stuff.
Add
something like this to the end (substitute the real path to your stuff):

            export PATH=${PATH}:/var/lib/gems/1.8/bin

Later…
Richard

BTW: You’ll either have to log out or execute ‘source ~/.bashrc’ before
the
changes will show up.

Does the ‘rails’ command work?

If not, then wherever gem is installing executables isn’t in your path.

If so, then my guess is something went awry when Radiant installed,
have you tried a gem uninstall and then reinstall?

-James

Wow, I’m awed by the response!

I’m suspecting it’s the path as well, as to why it wasn’t set properly
with the gem install - I’ve no idea, maybe it’s something related to
the debian/ubuntu distro, rails works properly.

Echoing the path revealed that it’s Radiant isn’t listed:
main:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

My next question would have been what it would have been supposed to
be, but that was already answered! Therefore, the newly updated path
is:

main:~$ echo $PATH
$/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/var/lib/gems/1.8/bin

And radiant responds, I’m very grateful! (although I’m wondering why
Rails works while Radiant didn’t as they’re both installed through
gems).

Kindest regards,

Niko Kotiniemi

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs