Installation Problem

I need to install rails on my system for a class project. I have ruby
1.8.2-14 installed and am entering at the command prompt >gem install
rails --remote

According to Curt H. installation, I should get a series of questions
to answer yes to, and then info on the installation.

All I am getting is…
Successfully installed rails_analyzer_tools, version 1.1.0
Installing RDoc documentation for rails_analyzer_tools-1.1.0…

Any help would be greatly appreciated.

Try the following - it should automatically download all the required

gem install rails --include-dependencies

The problem is that you have an outdated version of rubygems.
Upgrade to the latest, then rinse, repeat.


I have tried that. I get…

ERROR: While executing gem … (OptionParser::InvalidOption)
invalid option: --include-dependencies

A simple option is to just download Instant Rails and run it from
there. No installation required; just unzip into a directory and run
it. It’s about as simple as an installation can get…

It contains several of the commonly used gems; at the very least,
it’ll get you going while you try to sort out the problem you’ve got.


Dave M.


[email protected] is not a ML for
reporting problems. If you want to use mail for reporting
them, please use
[email protected] If you want to
use Web interface, use a tracker on

In [email protected]
“installation problem” on Wed, 19 Mar 2008 16:24:24 +0100,
“Sergueï_Cambour” [email protected] wrote:

    from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in

require' from c:/ruby/lib/ruby/site_ruby/1.8/gtk2.rb:2 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
from -e:1

Can you please explain me what I did wrong ?

What version are you using?



Sean S. wrote:

The problem is that you have an outdated version of rubygems.
Upgrade to the latest, then rinse, repeat.


Thank you much. 'Tis working.


Remove Ruby-GNOME2 related files in
c:/ruby/lib/ruby/site_ruby/1.8/. Perhaps you installed them
before you use Win32 installer.



In [email protected]
“Re: installation problem” on Fri, 21 Mar 2008 09:53:17 +0100,

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs