Installation on Windows

Hi all,

The aim of this report is to share the experience of installing GNU
Radio on
Windows.

Operating system: Microsoft Windows XP Professional , Version 2002,
Service
Pack 2.

Operator level: Used to be very proficient some 10 years ago, now forgot
the
detail of syntax (and purpose) of a million of programming languages,
scripts, shells, packages, and variations. Loves programming (EE
background), but often lacks motivation and time to go through either
scarce
or endless pages of manuals.

*** MinGW/MSYS ***

Started of with Cygwin, installed OK. Downloaded FFTW. Had lots of
trouble
in Cygwin trying to use tar. Something probably wrong with paths.
Decided it
would be quicker to try MinGW/MSYS, as it seemed more user friendly.
Excellent decision - loved it. Everything seemed to just flow.

Used WinZip for zip files, tar for all else. Had to sometimes change
.tar.tar to .tar.gz manually.

Started downloading everything to c:\mingw. After installing MinSYS,
realised that all new things should go straight to its own directory
structure (ie mingw is only used my minsys - not sure if I got this
right).

Was able to find all versions listed for mingw/minsys on SourceForge.

Did not worry about anything listed under “NOTE:”.

Since installed MSYS first, edited /etc/fstab, as suggested.

*** Python ***

Was able to find all Python files listed, files installed without
problem.
Found DLL files OK.

*** SWIG ***

As per instructions. Left it in c:.

*** FFTW ***

As per instructions.

*** CppUnit ***

As per instructions. Had to create “src” under /usr. Was confused
whether it
should have been there already. In the end, creating was OK.

** PATH ***

Modified as directed. Did not bother with any scripts.

*** BOOST ***

As per instructions. Did not bother checking mounting.

*** PKGCONFIG ***

Took me forever to find these files. In the end realised should go to
http://ftp.gnome.org/pub/gnome/binaries/win32/ (a link from the main
page,
was not initially clear which package does what and how they were
connected). Then found all files under “glib/” and “dependencies/”
folders
on the FTP site. Then did as directed.

*** SDCC ***

Did as directed, also changed path.

*** SDL ***

Did as directed, copied the file. Realised the file copied was older
than
the file overwritten.

*** USB ***

Did as directed.

*** PortAudio ***

Did as directed. Encountered errors mentioned.

*** GNU Radio ***

Used version 3.0.4 (from memory could not find the mentioned one). Did
not
comment out anything. On first run of ./configure, encountered a problem
with swig. It said it could not find it, and it required version >=
…23…

Played around with the location of my swigwin directory for about a half
an
hour, but could not get ./configure to work. In the end decided to
download
…23… version. Did the same as above, and got it to work.

I think there is a problem in the ./configure script. It could be
related to
the swig naming system. Version …23… uses “SWIG”, while version
…31…
uses small-letters “swigwin” in the directory name.

On the next run, ./configure stopped at PKGCONFIG & FFTW.

Played around with the PATH variable in /usr/etc, also realised forgot
to
make install FFTW. Did that for FFTW, repeated the process from above
for
PKGCONFIG, and then it somehow worked.

Finally, got an error message (a Windows-like window now), saying it
could
not find SDL.dll (only OK button available). Went back and tried out
different things, like putting SDL.dll in different places, playing
around
with PATH, but nothing worked. When you click OK on the error message,
it
keeps going.

Decided to skip USRP for now.

Got the message shown, minus lines relating to usrp (which is OK). Did
not
end up having gr-video-sdl installed, which I will have to look into
later
on.

Did not comment out anything (not sure how this related to
gnuradio-3.0.4).
From memory, had an error message, but ignored it.

*** CONCLUSION ***

Connected speakers, and got the dial_tone.py working!!

Decided to write up the above for reference, as details are already
fading
(happened only 5 days ago). If more details are required, please
respond.

Out of all the files listed, with the exception of gnuradio-3.0.4, could
find the exact versions in all but perhaps 2 cases. Went to a higher
version, and it worked fine.

Probably ended up having too many directories in PATH.

Regards,
Petrovic.