Installation of Rb-GSL setup config problems

Dear all,

when I install rb-gsl in cygwin using the ruby setup.rb config command,
I get many repeating errors, each of the following form:

78678783 [main] ruby 2536 C:\cygwin\usr\local\bin\ruby.exe : *** fatal
error: unable to remap
C:\cygwin\usr\local\lib\ruby\1.8\i-386-cygwin\etc.so to same address as
parent
(0x2830000) != 0x2840000
65108726 [main] ruby 1440: child_copy: loaded dll child copy failed
0x28330000…0x2833170, done 0, windows pid 5468565, Win32 error 5.

These lines keep returning, with some differences in the windows pid
numbers
and in the
numbers before [main].

What is going on here? What could be done to fix it ?

Thank you very much!

Best regards,

Axel

On Sun, 7 May 2006 [email protected] wrote:

(0x2830000) != 0x2840000
65108726 [main] ruby 1440: child_copy: loaded dll child copy failed
0x28330000…0x2833170, done 0, windows pid 5468565, Win32 error 5.

These lines keep returning, with some differences in the windows pid numbers
and in the
numbers before [main].

What is going on here? What could be done to fix it ?

i think you’ve got more than one ruby on your system and/or have
upgraded ruby
or ruby extensions in a way that was not correct.

http://www.zope.org/Members/dgeorgieff/howto_zope_cvs_on_cygwin/

http://www.cygwin.com/ml/cygwin/2003-06/msg01241.html

http://kde-cygwin.sourceforge.net/kde3/faq.php

http://www.tishler.net/jason/software/rebase/rebase-2.4.2.README

in any case, this is purely a cygwin issue. sorry i can’t help more.

regards.

-a

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs