Installation de typo - prérequis


#1

bonsoir,
je voulais installer typo mais j’ai quelques questions sur ce qu’il faut
por
installer typo.
d’abord ruby 1.8.4 , ça ne marche qu’avec cette version ?
ensuite sqlite 3 , mysql ne suffit pas ?


#2

Le 28 janv. 2010 à 21:10, samuel a écrit :

bonsoir,
je voulais installer typo mais j’ai quelques questions sur ce qu’il faut por installer typo.
d’abord ruby 1.8.4 , ça ne marche qu’avec cette version ?
ensuite sqlite 3 , mysql ne suffit pas ?

Bonsoir Samuel

Ruby 1.8.4 ? Non, il faut la 1.8.6. Voilà ce que dit ma machine (une
référence en termes d’hébergement Typo) :
ruby 1.8.6 (2008-08-11 patchlevel 287) [x86_64-linux]

Ensuite, pour installer la gem il faut effectivement sqlite, mais tu
peux utiliser MySQL uniquement, après. Si tu n’as pas sqlite sur ta
machine, va prendre les sources sur
http://rubyforge.org/frs/?group_id=555

Bonne
soiréeFrédéric

Frédéric de Villamil
“What’s mine is mine. What’s yours is still unsetteled” – Go player
proverb
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#3

bonsoir frédéric,
j’ai trouvé la version dans installer.txt
http://github.com/fdv/typo/blob/master/doc/Installer.txt
sqilte ne devra pas être un problème vu que je vais l’installer sur
ubuntu… en tout cas je pense qu’un apt-get devrait suffir.
Je veux essayer de l’installer sur un server de test multi techno (
entre
autre php et ruby ) , il ne nécessite pas de mod ruby pour apache ?

Le 28 janvier 2010 21:53, de Villamil Frédéric
removed_email_address@domain.invalid a
écrit :


#4

Le 28/01/10 22:33, de Villamil Frédéric a écrit :

Ensuite, pour installer la gem il faut effectivement sqlite, mais tu peux utiliser MySQL uniquement, après. Si tu n’as pas sqlite sur ta machine, va prendre les sources sur http://rubyforge.org/frs/?group_id=555

Bonne soirée
Frédéric

Non, mod_rails passenger ou fcgi est parfait pour ça.

Tu devrais trouver un peu de doc en français par là http://t37.net/category/typo/ (flemme de chercher)

Sinon tu as mon fichier capistrano de déploiement d’application Typo.
Mis à jour pour la version 5.4.0 il faut changer pour mettre en 5.4.2

http://blog.shingara.fr/sortie-de-typo-5-4-0.html

Capistrano c’est le bien.

Enfin, je fais tourner Typo sur un serveur 1.8.7 et du postgreSQL. Je
fais toujours attention à enlever les particularités MySQL du code de
frédéric :stuck_out_tongue:

Sinon Thin c’est bien aussi :slight_smile:


Cyril M.
http://blog.shingara.fr/


#5

Le 28 janv. 2010 à 22:01, samuel a écrit :

d’abord ruby 1.8.4 , ça ne marche qu’avec cette version ?
Bonne soirée
Frédéric
Non, mod_rails passenger ou fcgi est parfait pour ça.

Tu devrais trouver un peu de doc en français par
http://t37.net/category/typo/ (flemme de chercher)


Frédéric de Villamil
“What’s mine is mine. What’s yours is still unsetteled” – Go player
proverb
removed_email_address@domain.invalid tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org


#6

bonjour
merci pour le lien je regarderai ce soir car j’ai eu quelques soucis
hier
j’en reparlerais peut être ce soir ( entre autre install des gem
passenger
et mysql )
typo ne fonctionne pas avec ruby1.9 ? enfin avec la dernière version
stable
quoi

Le 29 janvier 2010 12:24, Cyril M. removed_email_address@domain.invalid a écrit
:


#7

ok
merci
en fait j’installe typo pour mettre en place un petit blog et en
profitter
pour faire un peu ruby et ror

je peux installer ruby1.8 pour typo et la dernière version à jour
en parallèle?
Si oui, comment ça se passe pour les gems installées ou autre source de
conflits ?

Le 29 janvier 2010 12:38, Cyril M. removed_email_address@domain.invalid a écrit
:


#8

Le 29/01/10 12:34, samuel a écrit :

bonjour
merci pour le lien je regarderai ce soir car j’ai eu quelques soucis hier
j’en reparlerais peut être ce soir ( entre autre install des gem
passenger et mysql )
typo ne fonctionne pas avec ruby1.9 ? enfin avec la dernière version
stable quoi

Ni Fred, ni Matjis, ni moi n’avons réussi à faire tourner Typo avec Ruby 1.9

Par contre il existe un fork qui permet normalement de faire fonctionner
Typo avec Ruby1.9. Hélas il y a beaucoup de dépendance non
“conventiennel” car non compatible avec Ruby 1.9.

http://github.com/fdv/typo/blob/master/doc/Installer.txt
>>> bonsoir,
>> ruby 1.8.6 (2008-08-11 patchlevel 287) [x86_64-linux]
> Tu devrais trouver un peu de doc en français par là
http://t37.net/category/typo/ (flemme de chercher)
fais toujours attention à enlever les particularités MySQL du code de
"Railsfrance" de Google G..

Pour transmettre des messages à ce groupe, envoyez un e-mail à l’adresse
removed_email_address@domain.invalid
Pour résilier votre abonnement envoyez un e-mail à l’adresse
removed_email_address@domain.invalid


Cyril M.
http://blog.shingara.fr/


#9

bonsoir,
je reviens vous voir,
j’ai pas mal avancé avec tous les liens que vous m’aviez donné pour la
doc
de ubuntu mais je n’arrive pas à configurer apache.
J’aimerai avoir un sous domaine avec typo et un général avec une appli
php.

<VirtualHost *>
DocumentRoot /space/blog.lalop.fr/public
ServerName blog.lalop.fr

<VirtualHost *>
DocumentRoot /space/www.lalop.fr/web
ServerName www.lalop.fr
<Directory /space/www.lalop.fr/web>
allow from all
Options +Indexes

j’ai essayé plusieurs configurations mais je suis revenu au plus simple
pour
ne pas m’emmêler.
avec cette conf sur blog.lalop.fr j’ai une page d’erreur Serveur
introuvable
et une page d’erreur ror sur www.lalop.fr

Le 30 janvier 2010 10:32, Cyril M. removed_email_address@domain.invalid a écrit
:


#10

Le 02/02/10 21:30, samuel a écrit :

j’ai essayé plusieurs configurations mais je suis revenu au plus simple
pour ne pas m’emmêler.
avec cette conf sur blog.lalop.fr http://blog.lalop.fr j’ai une page
d’erreur Serveur introuvable et une page d’erreur ror sur www.lalop.fr
http://www.lalop.fr

Dans ton exemple de virtualhost, ca ne pointe pas sur une appli rails
que ca soit par proxy/FastCgi ou passenger. Donc c’est normal. C’est pas
du PHP.

>
>
>     > passenger et mysql )
>     Typo avec Ruby1.9. Hélas il y a beaucoup de dépendance non
>     >
suffir.
<mailto:removed_email_address@domain.invalid>>
>     >     >>> d'abord ruby 1.8.4 , ça ne marche qu'avec cette
>     >     >>
>     >     >
>     >     Capistrano c'est le bien.
>     >     Cyril M.
>     >     <mailto:removed_email_address@domain.invalid
>     <mailto:removed_email_address@domain.invalid
<mailto:removed_email_address@domain.invalid
>     http://blog.shingara.fr/
<mailto:removed_email_address@domain.invalid>
> Pour résilier votre abonnement envoyez un e-mail à l'adresse
"Railsfrance" de Google G..

Pour transmettre des messages à ce groupe, envoyez un e-mail à l’adresse
removed_email_address@domain.invalid
Pour résilier votre abonnement envoyez un e-mail à l’adresse
removed_email_address@domain.invalid


Cyril M.
http://blog.shingara.fr/


#11

Le 29/01/10 12:52, samuel a écrit :

ok
merci
en fait j’installe typo pour mettre en place un petit blog et en
profitter pour faire un peu ruby et ror

je peux installer ruby1.8 pour typo et la dernière version à jour
en parallèle?
Si oui, comment ça se passe pour les gems installées ou autre source de
conflits ?

Techniquement tu peux. Personnellement, j’utilise RVM (
http://rvm.beginrescueend.com/ ) qui me permet de bien gérer mes
diverses version de Ruby.

> typo ne fonctionne pas avec ruby1.9 ? enfin avec la dernière version
> Le 29 janvier 2010 12:24, Cyril M. <removed_email_address@domain.invalid
>     http://github.com/fdv/typo/blob/master/doc/Installer.txt
a écrit :
>     >>
>     >>
en 5.4.2
>
<mailto:removed_email_address@domain.invalid>
> Vous avez reçu ce message, car vous êtes abonné au groupe
Cyril M.


Vous avez reçu ce message, car vous êtes abonné au groupe “Railsfrance”
de Google G…
Pour transmettre des messages à ce groupe, envoyez un e-mail à l’adresse
removed_email_address@domain.invalid
Pour résilier votre abonnement envoyez un e-mail à l’adresse
removed_email_address@domain.invalid


Cyril M.
http://blog.shingara.fr/


#12

dans apache.conf j’ai

LoadModule passenger_module
/home/appart/.gem/ruby/1.8/gems/passenger-2.2.9/ext/apache2/mod_passenger.so
PassengerRoot /home/appart/.gem/ruby/1.8/gems/passenger-2.2.9
PassengerRuby /usr/bin/ruby1.8

et www.lalop.fr me mène bien vers une appli rails donc je pensais que
ça
suffisai de ce point de vue

Le 2 février 2010 22:14, Cyril M. removed_email_address@domain.invalid a écrit :


#13

au démarrage d’apache je n’ai rien dans les logs juste sur la console

  • Restarting web server apache2
    apache2: Could not reliably determine the server’s fully qualified
    domain
    name, using 127.0.0.1 for ServerName
    [Tue Feb 02 23:00:01 2010] [warn] NameVirtualHost *:80 has no
    VirtualHosts
    … waiting apache2: Could not reliably determine the server’s fully
    qualified domain name, using 127.0.0.1 for ServerName
    [Tue Feb 02 23:00:02 2010] [warn] NameVirtualHost *:80 has no
    VirtualHosts

je suis entrain de regarder ce que j’aurais pu rater sur l’install
d’apache
mais je ne vois pas.

Le 2 février 2010 22:50, Cyril M. removed_email_address@domain.invalid a écrit :


#14

Le 02/02/10 22:47, samuel a écrit :

dans apache.conf j’ai

LoadModule passenger_module
/home/appart/.gem/ruby/1.8/gems/passenger-2.2.9/ext/apache2/mod_passenger.so
PassengerRoot /home/appart/.gem/ruby/1.8/gems/passenger-2.2.9
PassengerRuby /usr/bin/ruby1.8

et www.lalop.fr http://www.lalop.fr me mène bien vers une appli rails
donc je pensais que ça suffisai de ce point de vue

Ca on pouvait pas savoir si tu ne nous le dit pas.

Regarde du coté des logs apache pour voir si il y en a. Je ne connais
pas assez passenger pour t’aider.


Cyril M.
http://blog.shingara.fr/


#15

en fait j’ai plus que le sous-domaine blog qui ne marche pas
mais c’est plus un soucis apache

Le 3 février 2010 00:07, samuel removed_email_address@domain.invalid a écrit :


#16

bonjour,
juste pour clore le sujet, je n’avais simplement pas déclaré le sous
domaine
dans les dns, je pensai que *.mondomaine.ext suffisait et qu’apache
faisait
le boulot… mais non

Le 3 février 2010 00:20, samuel removed_email_address@domain.invalid a écrit :


#17

bon j’ai réglé ces erreurs il fallait rajouter le port dans la balise
virtualhost
mais j’ai toujours www qui me donne blog et blog une erreur

Le 2 février 2010 23:01, samuel removed_email_address@domain.invalid a écrit :