Installation de RMagick sous Win32

Salut à tous,

Quelqu’un as t’il une solution simple pour installer RMagick sous Win ?

J’ai bien tenter un : gem install rmagick

Mais ca ne passe pas:

gem_extconf.rb:38: undefined method ‘exitstatus’ for nil:NilClass
(NoMethodError)
ERROR: While executing gem … (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in <MY_GEM_PATH>/rmagick-1.13.0 for
inspection.
ruby gem_extconf.rb install rmagick -y\n
sh configure

J’ai donc tester:

ruby gem_extconf.rb install rmagick -y

Mais n’ayant pas gem_extconf.rb ca ne passe pas.

Une idée ?


Sébastien Grosjean - ZenCocoon

Sébastien Grosjean (ZenCocoon) a écrit :

Salut à tous,

Quelqu’un as t’il une solution simple pour installer RMagick sous Win ?

J’ai bien tenter un : gem install rmagick

Mais ca ne passe pas:

Pas possible pour le moment, en fait seule une vieille version de
septembre 2005 fonctionne sous win mais elle n’est pas compatible avec
Ruby 1.8.4 me semble-t-il

cf http://rubyforge.org/forum/forum.php?forum_id=6439

Zambra wrote:

septembre 2005 fonctionne sous win mais elle n’est pas compatible avec
Ruby 1.8.4 me semble-t-il

cf http://rubyforge.org/forum/forum.php?forum_id=6439

En fait j’ai trouver un moyen, il faut télécharger le gem à la main:

http://rubyforge.org/frs/?group_id=12&release_id=3031

Et prendre la version Win32 1.9.2

Ensuite il suffit de lire le readme.html et tous marche bien.

P.S. : Je viens de tester avec file_column et tous semble ok.

Sébastien Grosjean - ZenCocoon

En fait j’ai trouver un moyen, il faut télécharger le gem à la main:

http://rubyforge.org/frs/?group_id=12&release_id=3031

Et prendre la version Win32 1.9.2

Ensuite il suffit de lire le readme.html et tous marche bien.

P.S. : Je viens de tester avec file_column et tous semble ok.

Tu es sous Ruby 1.8.4 ?

Tu es sous Ruby 1.8.4 ?

Oui, ruby -v :

ruby 1.8.4 (2005-12-24) [i386-mswin32]

Bizarre parce que Tim hunter avait dit “the RMagick 1.9.2 Win32 gem is
still available, although that version is only compatible with Ruby
1.8.2.”

Zambra wrote:

Tu es sous Ruby 1.8.4 ?

Oui, ruby -v :

ruby 1.8.4 (2005-12-24) [i386-mswin32]

Bizarre parce que Tim hunter avait dit “the RMagick 1.9.2 Win32 gem is
still available, although that version is only compatible with Ruby 1.8.2.”

En effet bizarre, mais je viens de jouer un peu avec et tous ce passe
bien.

Sébastien Grosjean - ZenCocoon

Zambra wrote:

Tu es sous Ruby 1.8.4 ?

Oui, ruby -v :

ruby 1.8.4 (2005-12-24) [i386-mswin32]


Sébastien Grosjean - ZenCocoon

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs