Installare ruby


#1

Ciao a tutti…
sono nuovo e mi chiaamo andrea…
per motivi universitari devo installare ruby on rails sul pc su sistema
operativo ubuntu…mi hanno consigliato di installare la versione 1.8.6
qualcuno mi dice come faccio?


#2

Ciao Andrea benvenuto e buon 2009.

Direi che per iniziare a preparare il campo di lavoro basta andare su:

e leggere la doc per l’installazione su linux/ubuntu.

Se invece vuoi partire direttamente, da shell potresti installare il
tutto con:

sudo apt-get install ruby ruby-dev irb rdoc rubygems libzlib-ruby
libyaml-ruby libmysql-ruby rails
(prevedo che tu abbia già mysql installato)

Dovresti avere quasi tutto ciò che ti serve per iniziare. Sempre da
terminale:

  • ruby -v
  • gem env
  • gem list

Per creare un nuovo progetto rails da terminale:
rails nome_progetto.

Il mio consiglio di capodanno è quello di leggere con attenzione i
getting start di ruby e rails. Non ti ci vorrà molto e servono.

Spero di esserti stato di aiuto.

A presto. Un saluto,
Ali.

Per qualunque altro dubbio segui la documentazione che trovi sui siti
che ti ho scritto prima.

Ancora buon anno e benvenuto a bordo


#3

Ci stavo ripensando:
… un grazie da parte mia alle discussioni, news di eventi e alle
persone che, anche solo leggendole, mi fanno apprezzare questa ML…

un saluto a reggie, chiaroscuro, carlo pecchia, renzi, ilramingo,marco,
vaccari…

bella da roma.
byz


#4

Ciao,

auguro a tutti “noi” un ottimo 2009 pieno di idee, progetti,
collaborazioni ed eventi.

A presto risentirvi,
Ali.


#5

On 1/1/09, Andrea R. removed_email_address@domain.invalid wrote:

2009/1/1 Ali P. removed_email_address@domain.invalid

un saluto a reggie, chiaroscuro, carlo pecchia, renzi, ilramingo,marco,
vaccari…
Un augurio speciale anche dalle zone di Treviso per una comunita’ rubista
piu’ attiva che mai in questo 2009!
Un abbraccio

un abbraccio a tutti.
questa community, con tutti quelli che vi ho conosciuto, mi ha cambiato
la
vita in direzioni imprevedibili :slight_smile:


#6

2009/1/1 Ali P. removed_email_address@domain.invalid

Ci stavo ripensando:
… un grazie da parte mia alle discussioni, news di eventi e alle
persone che, anche solo leggendole, mi fanno apprezzare questa ML…

un saluto a reggie, chiaroscuro, carlo pecchia, renzi, ilramingo,marco,
vaccari…

Un augurio speciale anche dalle zone di Treviso per una comunita’
rubista
piu’ attiva che mai in questo 2009!
Un abbraccio


Andrea R., http://mikamai.com
Writing http://sensejs.wordpress.com/
Collaborating http://therubymine.it
Reading http://stacktrace.it


#7

Auguri a tutti ragazzi (seppur in ritardo…) !!

Il 1 gennaio 2009 22.47, chiaro scuro removed_email_address@domain.invalid ha scritto:


#8

Se invece vuoi partire direttamente, da shell potresti installare il
tutto con:

sudo apt-get install ruby ruby-dev irb rdoc rubygems libzlib-ruby
libyaml-ruby libmysql-ruby rails
(prevedo che tu abbia gi� mysql installato)

Dovresti avere quasi tutto ci� che ti serve per iniziare. Sempre da
terminale:

  • ruby -v
  • gem env
  • gem list

Ok, domani provo… ma così mi installa l’ultima versione di ruby o la
1.8.6?