Install typo on windows / ckeditor & symlinks

Hi all,

my development machine is running under winXP. While trying to install
typo I get an error, saying that the symlink function is not available
on my machine, which is in fact correct. :wink:

Did anyone succeed in installing typo either without ckeditor or with a
patched ckeditor, which doesn’t need symlinks? Any advice would be
appreciated!

Best regards

Horst

Le 17/01/10 12:55, Horst Rischbode a écrit :

Best regards

Horst


Typo-list mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/typo-list

There are already a bug report about this issue (
https://fdv.lighthouseapp.com/projects/11171/tickets/138-windows-incompatibility-in-ckeditor
)

You can comment line where there are symlink and made a copy.

Hi Horst,

Horst Rischbode wrote:

Thanks! I edited /vendor/plugins/easy-ckeditor/lib/ckeditor_file_utils
to use cp instead of ln_s. Now, all works fine.

For a more comprehensive solution I suggest to change the above named
file to use the junction tool on windows machines.

What is the junction tool? Would you be able to create a patch for this?

Regards,

Hi Matjis,

Download & Basic Instruction:
http://technet.microsoft.com/en-gb/sysinternals/bb896768.aspx

More detailed discussion on symlinks under Windows:
http://shell-shocked.org/article.php?id=284#proggies

Junction is very much similar to symlinks on unix systems.

Sorry, but I’m not able to deliver a patch at the moment. Still trying
to get my first typo install running on windows. More and more, that
seems to be pain in the ass…

Actually, I can’t get bluecloth installed. But that’s off topic to this
thread…

Best Regards
Horst

Matijs van Zuijlen schrieb:

Hello,

When we were using FCKEditor on Typo, the editor used to copy the
config file if it didn’t exist. I don’t see why we should change that.

So I’m going to patch CKEditor plugin to have the same behavior.

Cheers,
Frédéric

Le 17 janv. 10 à 18:41, Horst Rischbode a écrit :

Sorry, but I’m not able to deliver a patch at the moment. Still
Matijs van Zuijlen schrieb:

file to use the junction tool on windows machines.
Typo-list mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/typo-list


Typo-list mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/typo-list


Frédéric de Villamil
“What’s mine is mine. What’s yours is still unsetteled” – Go player
proverb
[email protected] tel: +33 (0)6 62 19 1337
http://t37.net Typo : http://typosphere.org

Thanks! I edited /vendor/plugins/easy-ckeditor/lib/ckeditor_file_utils
to use cp instead of ln_s. Now, all works fine.

For a more comprehensive solution I suggest to change the above named
file to use the junction tool on windows machines.

Thanks again! Horst

Cyril M. schrieb:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs