Install ruby offline with openssl

Hi, all:
I know this is an old problem, but I still feel puzzled about it.
After I installed ruby in my computer, I found openssl is not available,
here’s the details:
I have two linux machines, one with Ubuntu6.06 and anther with SuSE10.0,
further more, I have a windows machine with windows XP.

I tried several times. Once I installed ruby in windows and gem install
rails, I could always find openssl.rb and openssl folder in my path,
which enable me use net/http very easily.

But I don’t get why once I installed ruby1.8.4 into my SuSE with a
download package, I can find openssl.rb and openssl directory in
/usr/local/lib/ruby/1.8; further more, once I tried to install ruby1.8.5
into my ubuntu, I encounter the same problem?!

I have read some solution with ubuntu, using “apt-get install
libssl-dev” or something else, I don’t know whether that’s because the
earthquake in Taiwan channel , I can’t connect to ubuntu update server
very well, meanwhile this online solution won’t solve the same problem
in SuSE.

So I wonder if I have to download some standalone ruby language packages
and install ruby offline, how could I make it support openssl as
well.(or did i missed some parameters while configure or make??)

Thanks very much!!


I think this could be described in one word, how could i install ruby
additional libraries with a download package.