Install RoR on Vista problem

Hi
I have tried to install RoR on my Vista machine but with no success
yet.

First I followed the tutorial getting started at RoR website &
everything worked up to the home page not showing in
http://localhost:3000
browser.

The Windows error message is:
<<>>>localhost is not set up to establish aconnection on port
3000 with this computer

I tried an internet search for help on opening ports in Vista and have
not found any suitable help yet!
I also run Xampp & IIS on my Vista machine (Xampp uses Apache server &
MySQL) & these are working fine (I followed internet articles to set
up & install them).

As this didn’t work I have tried installing RoR with Cygwin from this
youtube presentation:

(Cygwin with sqlite3)

This gets as far as opening the default homepage in
http://localhost:3000
but this is not correctly installed & I have this error at ‘About your
applications environment’:

About your application’s environment
We’re sorry, but something went wrong.
We’ve been notified about this issue and we’ll take a look at it
shortly.

I have spent somewhile trying to fix this but without success.

Can anyone please offer a solution? I look forward to helpful replies,
many thanks

Hi
Well sadly I had no reply to my original post for help about my RoR
being rubyOFFrails so I am replying now to my own post to update it.
I have now found a solution - I was using Ruby19 and windows vista
baulked at this (at one stage saying it could not find
mscrvtruby18.dll (?)). So I looked harder at the RoR download page &
it recommends Ruby 1.8.7
I could not find this but I uninstalled Ruby19 & have installed Ruby
1.8.6 instead and then followed an installation tutorial at

http://www.wdvl.com/Authoring/ror/Vista/saurabh_bhatia10202009.html

(using sqlite3-ruby & mongrel) & I have now the home page up & running
on localhost:3000- problem sorted!

Now I look forward to following the further instructions & developing
with RoR.

Well it is good to talk-even if it is only to yourself!
Maybe this post here though may help others to set up
without Ruby19 which wasn’t compatible with Rails for me! Goodluck…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs