Install into $HOME fails


#1

I don’t know how to install Ruby into my home directory. Looking
at the Makefile, I thought that

make prefix=$HOME install

should do the job, but make still tries to install into /usr/local
(which fails because I don’t have write-access there).

Any easy work-around to this?

Ronald


#2

I believe you need to specify the prefix on the ./configure step:

…/configure --prefix=$HOME


#3

removed_email_address@domain.invalid (Ronald F.) writes:

I don’t know how to install Ruby into my home directory. Looking
at the Makefile, I thought that

make prefix=$HOME install

should do the job, but make still tries to install into /usr/local
(which fails because I don’t have write-access there).

Any easy work-around to this?

./configure --prefix=$HOME
make
make install


#4

I don’t know how to install Ruby into my home directory. Looking
at the Makefile, I thought that

make prefix=$HOME install

should do the job, but make still tries to install into /usr/local
(which fails because I don’t have write-access there).

/configure --prefix=$HOME

Thank you, this works.

It would be great if this information could be put into the README.

Ronald


#5

removed_email_address@domain.invalid (Ronald F.) writes:

Thank you, this works.

It would be great if this information could be put into the README.

The README says to run ./configure to generate the Makefile.
…/configure --help tells you all the configure options.

The configure script, and its --help option, is standard for things
that use autoconf (lots of stuff in the free software world). I guess
it couldn’t hurt to mention --help in the README, though.