Install from source on CentOS question

I am attempting to install 1.9.1 from source on CentOS 5.4 and am
running into an issue.

after unpacking the archive and cd-ing into the ruby-1.9.1-p376 I run:
./configure --with-openssl-dir=/usr/lib/openssl

but the last line of the output shows:
config.status: creating Makefile
configure: WARNING: unrecognized options: --with-openssl-dir

What do I need to do to get the creation of the makefile to not throw
that warning?

Hi Cameron,

I am new to Ruby and I came across this same problem when I was
installing
ruby for the first time on my Ubuntu box. But after spending some time
on
it, I found the following steps works without much of a problem for
installing ruby with openssl.

Ignore the --with-openssl-dir: I think the problem is to say with using
[dash][dash]with-openssl-dir instead of [dash][dash]
[dash][dash]with-openssl-dir. Google for the same and you will find the
reason

Instead, try this approach:

  1. Install ruby with ./configure --prefix = /installation_path
  2. Download openssl source and run ./config --perfix= /installation_path
    Note: OpenSSL 1.0.X version doesn’t seems to be working with ruby.
    OpenSSL-0.9.8n worked for me. Also use the same $installation_path for
    both
    ‘prefix’ declarations. e.g., --prefix=/usr/local
  3. Complete OpenSSL installation.
  4. Go back to the ruby-1.8.6-pxxx/ext/openssl folder and run - ruby
    extconf.rb, make, make install respectively.

Now I am sure, all the required packages for openssl can be identified
by
ruby whenever required.

Hope this helps. I have also blogged about the same in the following
location. Feel free to check this out too.
http://theflashesofinsight.wordpress.com/2010/04/29/ubuntu-rails-fix-starting-webrick-openssl-issue/

With be glad to hear from the group if there are any better solutions.

Thanks

v4 forums wrote:

With be glad to hear from the group if there are any better solutions.

There’s no need to install openssl from source. Just install the
openssl-devel package before building ruby (yum install openssl-devel)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs