Instalation problem

HI!!
I’m a complete newby and I’m trying to follow a tutorial on learning
ruby on rails.
I am on a new mac and require an updated version of ruby to follow
the tutorial. Everything I’ve read has pointed me towards downloading
and using RVM.
I typed \curl -L https://get.rvm.io | bash -s stable --ruby in my
terminal and this is a shortened version of what happened:

Upgrade of RVM in /Users/carlosamengual/.rvm/ is complete.

Carlos Amengual,

Thank you for using RVM!

I sincerely hope that RVM helps to make your life easier and

more enjoyable!!!

~Wayne

rvm 1.18.8 (stable) by Wayne E. Seguin [email protected], Michal
Papis [email protected] [https://rvm.io/]

Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.8/x86_64/ruby-1.9.3-p385.
Continuing with compilation. Please read ‘rvm mount’ to get more
information on binary rubies.
Fetching yaml-0.1.4.tar.gz to /Users/carlosamengual/.rvm/archives
Extracting yaml to /Users/carlosamengual/.rvm/src/yaml-0.1.4
Configuring yaml in /Users/carlosamengual/.rvm/src/yaml-0.1.4.
Error running ‘env LDFLAGS=-L/opt/sm/pkg/active/lib
CFLAGS=-I/opt/sm/pkg/active/include CPATH=/opt/sm/pkg/active/include
./configure --prefix=/Users/carlosamengual/.rvm/usr --disable-shared’,
please read
/Users/carlosamengual/.rvm/log/ruby-1.9.3-p385/yaml/configure.log
Compiling yaml in /Users/carlosamengual/.rvm/src/yaml-0.1.4.
Error running ‘make -j2’, please read
/Users/carlosamengual/.rvm/log/ruby-1.9.3-p385/yaml/make.log
Installing Ruby from source to:
/Users/carlosamengual/.rvm/rubies/ruby-1.9.3-p385, this may take a while
depending on your cpu(s)…
ruby-1.9.3-p385 - #downloading ruby-1.9.3-p385, this may take a while
depending on your connection…
ruby-1.9.3-p385 - #extracted to
/Users/carlosamengual/.rvm/src/ruby-1.9.3-p385 (already extracted)
ruby-1.9.3-p385 - #configuring
Error running ‘env LDFLAGS=-L/opt/sm/pkg/active/lib
CFLAGS=-I/opt/sm/pkg/active/include CPATH=/opt/sm/pkg/active/include
./configure --disable-install-doc
–prefix=/Users/carlosamengual/.rvm/rubies/ruby-1.9.3-p385
–with-opt-dir=/Users/carlosamengual/.rvm/usr --disable-shared’, please
read /Users/carlosamengual/.rvm/log/ruby-1.9.3-p385/configure.log
There has been an error while running configure. Halting the
installation.

I see that rvm has been installed, but something has obviously gone
wrong…any ideas. This is like the third time I’m doing it because when
I try and install an updated version of Ruby I get similar messages.
Thanks in advanced for your help.

I am on Mac too. I installed rvm. I had the same error message you got.
I am sorry for not having a clear answer but even if I had this error
message, ultimately everything worked perfectly: rvm, ruby 1.9.3
installed.
I am not being arrogant but just want to make sure that you are not
being alarmed for no reason. Are you sure the installation is not
actually completed?
What do you see when typing this code in you Terminal? which ruby
or you can type: ruby -v

On Thu, Feb 21, 2013 at 04:57:39AM +0900, Carlos A. wrote:

I don’t use rvm but it sounds like you did not install Xcode which is
needed to compile ruby. You can get it from the app store

You might get more information using these commands: ‘rvm notes’ and
‘rvm
requirements’.

Since there’s also compilation problems lately related to recent Xcode
versions, https://rvm.io/os/osx/ could be helpful

I also have Xcode installed, but have not done anything with…do I have
to do something with it??
Thanks again!!

Yes! You have to install the command line tools. There are different
version depending on what version of Mac OS X you are using, but you can
either download the command line tools directly from Apple here:

https://developer.apple.com/downloads/index.action

or from within Xcode. You have to open he Preferences and in the
Downloads tab there is a listing for Command Line Tools. Click the
install button next to it and that will install all the parts needed.

Wayne

Hakim B. wrote in post #1098061:

I am on Mac too. I installed rvm. I had the same error message you got.
I am sorry for not having a clear answer but even if I had this error
message, ultimately everything worked perfectly: rvm, ruby 1.9.3
installed.
I am not being arrogant but just want to make sure that you are not
being alarmed for no reason. Are you sure the installation is not
actually completed?
What do you see when typing this code in you Terminal? which ruby
or you can type: ruby -v

Hi,
My version is the same as prior to doing anything. ruby 1.8.7!!
This is driving me crazy!!
I also have Xcode installed, but have not done anything with…do I have
to do something with it??
Thanks again!!

On Thu, Feb 21, 2013 at 4:39 AM, Carlos A. [email protected] wrote:

this other pkg-config.
You must have previously installed the SM framework https://smf.sh/.
It most likely put a line near the end of your .bashrc or .profile or
.bash_profile that adds its bin directories to your PATH; try
commenting that out. (I’m not sure what to advise if you actually need
to use SM; and this warning from Homebrew may not even be anything to
worry about.)

Prefect!! Thanks for your help!!
I’ve now got Xcode up and running and GCC is also good!
Now I’m having problems with Homebrew…when I type brew doctor I get
this message:

Warning: You have a non-Homebrew ‘pkg-config’ in your PATH:
/opt/sm/pkg/active/bin/pkg-config

./configure may have problems finding brew-installed packages using
this other pkg-config.

The tutorial says it should say ‘Your system is rearing to brew’
Any ideas?!?!
Thanks!!

Eric C. wrote in post #1098256:

On Thu, Feb 21, 2013 at 4:39 AM, Carlos A. [email protected] wrote:
It most likely put a line near the end of your .bashrc or .profile or
.bash_profile that adds its bin directories to your PATH; try
commenting that out.

Sorry, but I am just starting out with all of this…how would I do
that??

Thanks!!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs